summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20210608.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index d49f6f227540..8aa65dfc4073 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20201129.tar.xz 28372 BLAKE2B b59d94a69b83f8db9193bd54ff6059b20617b6dd60c0f9a0ec5acdf4b93adf747886598b9af7d69d2fd9705fab709041a96c149286e623b6557ea709bf2f840a SHA512 7b49795ea266d90e45c48b092bffa485a7207c66550d797297cb7e0756f7c497d045b3cb9b90f50b80a3ada4916a3ba273b2c19b9d02c834fb47d906efe3a8ba
+DIST crossdev-20210608.tar.xz 28464 BLAKE2B 5a52427b86b0dbfaf5711a04382486ff247ba69ff18bdad4840f173e7ba55efe547aad550086570335377192ec9b3f0b36da1921ad7044b9e21bb2bd3a21779e SHA512 246eb7ce4db4a6fe8af461700878e30c2f83548c72960aba7e936b1bbb4e83cfdc1fe39b6fd21924075b745ff87130d0b8a5ce569c49474e0e0432f85a74c89c
diff --git a/sys-devel/crossdev/crossdev-20210608.ebuild b/sys-devel/crossdev/crossdev-20210608.ebuild
new file mode 100644
index 000000000000..edc534a73039
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20210608.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}