summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/Manifest1
-rw-r--r--sys-devel/gcc-config/gcc-config-2.2.1.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 23d86970cc11..d753879ffd92 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1,3 +1,2 @@
-DIST gcc-config-2.2.1.tar.xz 16292 BLAKE2B bed319b73bb1dd1c693715654dab7d16c12929353eb28c6e93ffeda0d4539d8204e84287c58de65ed5198011130a6e0ef71421cf41e7cf59cc48781a94ec9af2 SHA512 783caf2f4236d7c84e7c76c2d001d069a1b8544644d7e6e12b79f4dc55f34c953a24a8cd8d01b2aa69fa7f8e02ec3380e0e33a83eda6b3cb00e8c43d2f69f673
DIST gcc-config-2.3.1.tar.xz 17368 BLAKE2B 59c77938b24cbbb548ef2f9e68be0de8c651f6beca74cf4e6007338f6217fa6e207c020f9a5e1c05c6abae24b9628fd193d0aeaaea28c6a1aac51e48b0145118 SHA512 7d7cdcd1aaaadb32e95227f61166b4390476d080e90387a167f031ef5c2c88dd3c785297946435500e39ed9bc31c0b5369cdacf1a12e75cd1786ba30bf7e407a
DIST gcc-config-2.3.tar.xz 16736 BLAKE2B e8c22348d73ec756ebe377c3f9b0aca8e22b7ef53507bfa4dc0fbd459bca38ba6bea9dbb290b4d83239c21c913d12f8262a263e1c078a3997558a0b14fdf355d SHA512 4ce1e46bee6b2182c664746d939a7d843d5b4323c860ea3ee24e36aa629e65f3aa99da99905d4a7091ad0a3a37c14a6a56a0f79c76d6bc93fa0dad39552f221d
diff --git a/sys-devel/gcc-config/gcc-config-2.2.1.ebuild b/sys-devel/gcc-config/gcc-config-2.2.1.ebuild
deleted file mode 100644
index defb04078d85..000000000000
--- a/sys-devel/gcc-config/gcc-config-2.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
- inherit git-r3
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-fi
-
-DESCRIPTION="Utility to manage compilers"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=sys-apps/gentoo-functions-0.10"
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- PV="${PV}" \
- SUBLIBDIR="$(get_libdir)"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- PV="${PV}" \
- SUBLIBDIR="$(get_libdir)" \
- install
-}
-
-pkg_postinst() {
- # Scrub eselect-compiler remains
- rm -f "${ROOT}"/etc/env.d/05compiler &
-
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- rm -f "${ROOT}"/usr/include/g++{,-v3} &
-
- # Do we have a valid multi ver setup ?
- local x
- for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
- gcc-config ${x}
- done
-
- wait
-}