summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild')
-rw-r--r--sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild b/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild
new file mode 100644
index 000000000000..bfd7e8603e50
--- /dev/null
+++ b/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+MY_PV="$(ver_cut 1-2)-$(ver_cut 3-4)"
+
+DESCRIPTION="OpenIB uverbs micro-benchmarks"
+HOMEPAGE="https://github.com/linux-rdma/perftest/"
+SRC_URI="https://github.com/linux-rdma/perftest/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="|| ( GPL-2 BSD-2 )"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+
+DEPEND="
+ sys-apps/pciutils
+ >=sys-cluster/rdma-core-32.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc README runme
+ dobin ib_*
+}