summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/firmware-imx/firmware-imx-5.4.ebuild')
-rw-r--r--sys-firmware/firmware-imx/firmware-imx-5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
new file mode 100644
index 000000000000..ddd2096e89ce
--- /dev/null
+++ b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="NXP i.MX firmware"
+HOMEPAGE="http://www.timesys.com/"
+SRC_URI="http://repository.timesys.com/buildsources/${PN:0:1}/${PN}/${P}/${P}.bin"
+LICENSE="LA_OPT_BASE_LICENSE"
+SLOT="0"
+KEYWORDS="~arm"
+
+S="${WORKDIR}/${P}/firmware"
+
+src_unpack() {
+ eval local $(grep -a -m1 "^filesizes=" "${DISTDIR}/${A}")
+ tail -c"${filesizes}" "${DISTDIR}/${A}" > "${P}.tar.bz2" || die
+ unpack "./${P}.tar.bz2"
+}
+
+src_prepare() {
+ default
+ find -name "*.mk" | xargs rm -v || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r epdc sdma vpu
+}