summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/seabios/seabios-1.8.2.ebuild')
-rw-r--r--sys-firmware/seabios/seabios-1.8.2.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-firmware/seabios/seabios-1.8.2.ebuild b/sys-firmware/seabios/seabios-1.8.2.ebuild
index 61b1a8d77671..23e935b8e815 100644
--- a/sys-firmware/seabios/seabios-1.8.2.ebuild
+++ b/sys-firmware/seabios/seabios-1.8.2.ebuild
@@ -32,9 +32,10 @@ HOMEPAGE="http://www.seabios.org"
LICENSE="LGPL-3 GPL-3"
SLOT="0"
-IUSE="+binary +seavgabios"
+IUSE="+binary debug +seavgabios"
-REQUIRED_USE="ppc? ( binary )
+REQUIRED_USE="debug? ( !binary )
+ ppc? ( binary )
ppc64? ( binary )"
DEPEND="
@@ -73,7 +74,14 @@ src_prepare() {
}
src_configure() {
- use binary || tc-ld-disable-gold #438058
+ use binary && return
+
+ tc-ld-disable-gold #438058
+
+ if use debug ; then
+ echo "CONFIG_DEBUG_LEVEL=8" >.config
+ fi
+ _emake config
}
_emake() {