summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/fatcat/fatcat-1.1.0-r2.ebuild')
-rw-r--r--sys-fs/fatcat/fatcat-1.1.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..1b785a18b115
--- /dev/null
+++ b/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+ cmake_src_install
+ doman man/${PN}.1
+ dodoc docs/*.md
+}