summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/hfsplusutils')
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch27
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch
new file mode 100644
index 000000000000..dde912d4ef62
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch
@@ -0,0 +1,27 @@
+--- a/libhfsp/src/fscheck.c
++++ b/libhfsp/src/fscheck.c
+@@ -47,6 +47,8 @@
+ # include "os.h"
+ # include "swab.h"
+
++struct fsck_data_t fsck_data;
++
+ /* Dump all raw fork information to stdout */
+ void print_fork(hfsp_fork_raw* f)
+ {
+--- a/libhfsp/src/fscheck.h
++++ b/libhfsp/src/fscheck.h
+@@ -100,10 +100,11 @@
+ int fscheck_files(volume* vol);
+
+ /** global data used during fsck */
+-struct {
++struct fsck_data_t {
+ UInt32 maxCnid;
+ UInt32 macNow; // current date in mac-offset
+ int verbose;
+ int ignoreErr;
+-} fsck_data;
++};
+
++extern struct fsck_data_t fsck_data;
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
index 4e624f1b33c8..a578df335018 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-string.patch
"${FILESDIR}"/${P}-stdlib.patch
"${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-fno-common-gcc10.patch
)
src_prepare() {