summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/jdiskreport-bin')
-rw-r--r--sys-fs/jdiskreport-bin/Manifest3
-rw-r--r--sys-fs/jdiskreport-bin/jdiskreport-bin-1.2.5-r1.ebuild32
-rw-r--r--sys-fs/jdiskreport-bin/jdiskreport-bin-1.3.0.ebuild32
-rw-r--r--sys-fs/jdiskreport-bin/jdiskreport-bin-1.4.1.ebuild32
-rw-r--r--sys-fs/jdiskreport-bin/metadata.xml11
5 files changed, 110 insertions, 0 deletions
diff --git a/sys-fs/jdiskreport-bin/Manifest b/sys-fs/jdiskreport-bin/Manifest
new file mode 100644
index 000000000000..e7e436537ed4
--- /dev/null
+++ b/sys-fs/jdiskreport-bin/Manifest
@@ -0,0 +1,3 @@
+DIST jdiskreport-1_2_5.zip 613585 SHA256 30efef5f5e75ed6f51a9a3973711960c5eccae503edcf00f728948d6b19b12d2 SHA512 d23641610a9fba6b7b2c5d529244229e807d89bd2b4c339e59522547f3b45a32415d6819a4ee8d5bd4a8789ea4610887428bfd5a5a4c56b11911da035a560993 WHIRLPOOL 8c2f13ca29e4184117cd20a684b8e9d7ab60abeeaab260b5d8dbeb5430013543c8ca872814c2c23da5f74e0e932ff6da4e287e867a556918fb4620d7dde779ff
+DIST jdiskreport-1_3_0.zip 650433 SHA256 abc308ef722023db5384cb98d251e4e458ab4f794c4fc2138a86e177d2c1f1ed SHA512 9d57e7db810117a27c1d8d2aef40113652f25055e3512500fdf5f8806b1d68f4be8b4231e281d690108301afde3cc6b70f061c71d3fafef06689ca3228dd44ea WHIRLPOOL a39b9843a5a1e456e621b50c4967be2905755addcff0cf80e79baea88efbb628d6f1a48537ac9f1bedb2d87d9f0a067d8e921ea5f87619c4227da9d12c4a16b4
+DIST jdiskreport-1_4_1.zip 864613 SHA256 a834d3b50bcba0711caff7284103c16025c03057ea6ebfc34a3ac1a5f9fcb534 SHA512 c1e17bdaab739561ae46475d69805e18be271a0d41b555e981cde59091d6c46fe3cf6775bdd992200edbb4646b7a04003a6b67bfedc18161952a20e47b18ea38 WHIRLPOOL 07266fc401ce0c0d74cf30b96974119c3277bdad0971f9ca66347d2d15052e0cba58072572b4b8615762c72fcffd5a0a71df876454dd0d1683ce06502328f513
diff --git a/sys-fs/jdiskreport-bin/jdiskreport-bin-1.2.5-r1.ebuild b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..e4e96d85c586
--- /dev/null
+++ b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.2.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_PN=${PN/-bin/}
+MY_PV=${PV//\./_}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JDiskReport helps you to understand disk drive usage"
+HOMEPAGE="http://www.jgoodies.com/freeware/jdiskreport/"
+SRC_URI="http://www.jgoodies.com/download/${MY_PN}/${MY_P}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ java-pkg_newjar ${MY_PN}-${PV}.jar
+ java-pkg_dolauncher ${MY_PN}
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+}
diff --git a/sys-fs/jdiskreport-bin/jdiskreport-bin-1.3.0.ebuild b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.3.0.ebuild
new file mode 100644
index 000000000000..e4e96d85c586
--- /dev/null
+++ b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_PN=${PN/-bin/}
+MY_PV=${PV//\./_}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JDiskReport helps you to understand disk drive usage"
+HOMEPAGE="http://www.jgoodies.com/freeware/jdiskreport/"
+SRC_URI="http://www.jgoodies.com/download/${MY_PN}/${MY_P}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ java-pkg_newjar ${MY_PN}-${PV}.jar
+ java-pkg_dolauncher ${MY_PN}
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+}
diff --git a/sys-fs/jdiskreport-bin/jdiskreport-bin-1.4.1.ebuild b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.4.1.ebuild
new file mode 100644
index 000000000000..3ba865fc2db9
--- /dev/null
+++ b/sys-fs/jdiskreport-bin/jdiskreport-bin-1.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+MY_PN=${PN/-bin/}
+MY_PV=${PV//\./_}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JDiskReport helps you to understand disk drive usage"
+HOMEPAGE="http://www.jgoodies.com/freeware/jdiskreport/"
+SRC_URI="http://www.jgoodies.com/download/${MY_PN}/${MY_P}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ java-pkg_newjar ${MY_PN}-${PV}.jar
+ java-pkg_dolauncher ${MY_PN}
+
+ dodoc README.txt RELEASE-NOTES.txt || die
+}
diff --git a/sys-fs/jdiskreport-bin/metadata.xml b/sys-fs/jdiskreport-bin/metadata.xml
new file mode 100644
index 000000000000..da3a594a0008
--- /dev/null
+++ b/sys-fs/jdiskreport-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ JDiskReport enables you to understand how much space the files and
+ directories consume on your disk drives, and it helps you find obsolete
+ files and folders.
+ </longdescription>
+</pkgmetadata>
+