summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild')
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
index 161eca8ce48e..f936c78e267e 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -9,6 +9,7 @@ if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
+ inherit libtool
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
@@ -30,7 +31,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ if [[ ${PV} = "9999" ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {