summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.19.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index eb808d7e3e5f..2ab39b4d0182 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,3 +1,4 @@
DIST xfsprogs-4.14.0.tar.xz 1137048 BLAKE2B b58373ca7f58e5d887cf18ed2aab169aed4ba233a50f1f1ff41eaf0dcd039ae290f1e49b385da19ceff3a34e770f90943502eefd7c1469c5cba74f45185fd07e SHA512 69832a1b9636dc5a77ad277122bb24bc09c71ad743c3ab5bf830d398557e63fa1477dd08c6115a53a94f01fc27e58d70268416013cc25e026baed7a74af8d506
DIST xfsprogs-4.17.0.tar.xz 1205508 BLAKE2B 46168792c1e4c335b7ed9e7489afc20d7df4b4e554eb86043b2c19303879491cc4746b18d23fdff3e2f92ca3887ac27957ae57e85ba784476d8891ea6909d67e SHA512 996de920c76de596b6175e4ae4ba9de208c16fbcf9362bbb44d25ee1c12b249d0178fc5cc93dc5a434ab20e6d515d64a3f51b8e89905b5b033b28a3638f4d400
DIST xfsprogs-4.18.0.tar.xz 1214480 BLAKE2B 78db41319e53be1f03b66f85ecc7c50e0c6658fa3fd8ddd8539bac04e656614a5cb54dc930a324d9df6afe4024c2be10259b903e1ca0ccd0ffb340e7410692c2 SHA512 0629400f8824620138928a7d72908b7a852408814238a55e11d6eb3b2da42cd56273960430d3ea729a9bce95f605d225607940d4728b68c468c39eb5a9a590be
+DIST xfsprogs-4.19.0.tar.xz 1212852 BLAKE2B 2d04390765c5e0dd7d51366f0310c9e680651d49bdd1ecd220b4eec50540a66c97bf6e54f976414351bc77381ffd463803836b27ca25b53960a278a34bc09775 SHA512 a96d0ce406534e70b0a531dfab296de420ec710cd0682dffaf5211602adf82dd59f84b9eb7793c54eabb782a9e0229acf7b247ab644d531ee9e5b51fe9dc0f58
diff --git a/sys-fs/xfsprogs/xfsprogs-4.19.0.ebuild b/sys-fs/xfsprogs/xfsprogs-4.19.0.ebuild
new file mode 100644
index 000000000000..6e3d050f54b1
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-4.19.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs multilib systemd
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="icu libedit nls readline static-libs"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ icu? ( dev-libs/icu:=[static-libs(+)] )
+ readline? ( sys-libs/readline:0=[static-libs(+)] )
+ !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
+ !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.0-underlinking.patch
+ "${FILESDIR}"/${PN}-4.15.0-sharedlibs.patch
+ "${FILESDIR}"/${PN}-4.15.0-docdir.patch
+)
+
+pkg_setup() {
+ if use readline && use libedit ; then
+ ewarn "You have USE='readline libedit' but these are exclusive."
+ ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Clear out -static from all flags since we want to link against dynamic xfs libs.
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in || die
+ # Don't install compressed docs
+ sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+ find -name Makefile -exec \
+ sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
+}
+
+src_configure() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+
+ local myconf=(
+ --disable-lto #655638
+ --enable-blkid
+ --with-crond-dir="${EPREFIX}/etc/cron.d"
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
+ $(use_enable nls gettext)
+ $(use_enable readline)
+ $(usex readline --disable-editline $(use_enable libedit editline))
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+
+ MAKEOPTS+=" V=1"
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" install
+ # parallel install fails on this target for >=xfsprogs-3.2.0
+ emake -j1 DIST_ROOT="${ED}" install-dev
+
+ # handle is for xfsdump, the rest for xfsprogs
+ gen_usr_ldscript -a handle xcmd xfs xlog frog
+ # removing unnecessary .la files if not needed
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}