summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/hfsutils/files/hfsutils-3.2.6-errno.patch5
-rw-r--r--sys-fs/hfsutils/files/hfsutils-3.2.6-fix-tcl-8.6.patch4
-rw-r--r--sys-fs/hfsutils/files/largerthan2gb.patch4
-rw-r--r--sys-fs/hfsutils/hfsutils-3.2.6-r6.ebuild (renamed from sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild)20
4 files changed, 15 insertions, 18 deletions
diff --git a/sys-fs/hfsutils/files/hfsutils-3.2.6-errno.patch b/sys-fs/hfsutils/files/hfsutils-3.2.6-errno.patch
index 6e25f794b220..f8ab6a0bf0a0 100644
--- a/sys-fs/hfsutils/files/hfsutils-3.2.6-errno.patch
+++ b/sys-fs/hfsutils/files/hfsutils-3.2.6-errno.patch
@@ -1,6 +1,5 @@
-diff -ruN hfsutils.orig/tclhfs.c hfsutils-3.2.6/tclhfs.c
---- hfsutils.orig/tclhfs.c 2003-03-31 17:34:55.000000000 +0200
-+++ hfsutils-3.2.6/tclhfs.c 2003-03-31 17:39:51.000000000 +0200
+--- a/tclhfs.c
++++ b/tclhfs.c
@@ -43,8 +43,7 @@
# include "charset.h"
# include "suid.h"
diff --git a/sys-fs/hfsutils/files/hfsutils-3.2.6-fix-tcl-8.6.patch b/sys-fs/hfsutils/files/hfsutils-3.2.6-fix-tcl-8.6.patch
index 19f15424543c..8faf06e0f77a 100644
--- a/sys-fs/hfsutils/files/hfsutils-3.2.6-fix-tcl-8.6.patch
+++ b/sys-fs/hfsutils/files/hfsutils-3.2.6-fix-tcl-8.6.patch
@@ -1,5 +1,5 @@
---- hfsutils-3.2.6/config.h.in
-+++ hfsutils-3.2.6/config.h.in
+--- a/config.h.in
++++ b/config.h.in
@@ -91,3 +91,5 @@
# ifndef HAVE_STRTOL
long strtol(const char *, char **, int);
diff --git a/sys-fs/hfsutils/files/largerthan2gb.patch b/sys-fs/hfsutils/files/largerthan2gb.patch
index a688ff621a30..fb9fb7787f9c 100644
--- a/sys-fs/hfsutils/files/largerthan2gb.patch
+++ b/sys-fs/hfsutils/files/largerthan2gb.patch
@@ -1,5 +1,5 @@
---- libhfs/os/unix.c-orig 1998-11-02 23:09:13.000000000 +0100
-+++ libhfs/os/unix.c 2004-12-13 14:39:28.099124272 +0100
+--- a/libhfs/os/unix.c
++++ b/libhfs/os/unix.c
@@ -19,6 +19,11 @@
* $Id$
*/
diff --git a/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild b/sys-fs/hfsutils/hfsutils-3.2.6-r6.ebuild
index 1d19c5f6f8e0..23076395fd73 100644
--- a/sys-fs/hfsutils/hfsutils-3.2.6-r5.ebuild
+++ b/sys-fs/hfsutils/hfsutils-3.2.6-r6.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils toolchain-funcs
+EAPI=7
+inherit toolchain-funcs
DESCRIPTION="HFS FS Access utils"
HOMEPAGE="https://www.mars.org/home/rob/proj/hfs/"
@@ -21,15 +20,14 @@ RDEPEND="${DEPEND}"
# use tk requires tcl - bug #150437
REQUIRED_USE="tk? ( tcl )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-errno.patch \
- "${FILESDIR}"/largerthan2gb.patch \
- "${FILESDIR}"/${P}-fix-tcl-8.6.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-errno.patch
+ "${FILESDIR}"/largerthan2gb.patch
+ "${FILESDIR}"/${P}-fix-tcl-8.6.patch
+)
src_configure() {
+ tc-export CC
econf $(use_with tcl) $(use_with tk)
}