summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/udev-246.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-fs/udev/udev-246.ebuild b/sys-fs/udev/udev-246.ebuild
index 0727fffde02f..f3f86995214c 100644
--- a/sys-fs/udev/udev-246.ebuild
+++ b/sys-fs/udev/udev-246.ebuild
@@ -9,10 +9,15 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
else
+ if [[ ${PV} == *.* ]]; then
+ MY_PN=systemd-stable
+ else
+ MY_PN=systemd
+ fi
MY_PV=${PV/_/-}
- MY_P=systemd-${MY_PV}
+ MY_P=${MY_PN}-${MY_PV}
S=${WORKDIR}/${MY_P}
- SRC_URI="https://github.com/systemd/systemd/archive/v${MY_PV}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/systemd/${MY_PN}/archive/v${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
fi