summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/genkernel/files')
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-chroot-path.patch49
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-devicemanager.patch72
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-fix-btrfs-progs-deps.patch24
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-fuse-glibc-2.34.patch77
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-gcc-12-boost-1.79.patch28
-rw-r--r--sys-kernel/genkernel/files/genkernel-4.2.6-slibtool.patch106
6 files changed, 0 insertions, 356 deletions
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-chroot-path.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-chroot-path.patch
deleted file mode 100644
index 150506c454c8..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-chroot-path.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-https://gitweb.gentoo.org/proj/genkernel.git/commit/?id=33394fef9f712ca0854eca248fe85863771ca04a
-
-From: "Andreas K. Hüttel" <dilfridge@gentoo.org>
-Date: Mon, 16 May 2022 21:31:34 +0200
-Subject: linuxrc: do not rely on chroot evaluating PATH
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-When trying to install a new kernel on catbus.sparc.dev.gentoo.org, the
-newly built initrd consistently claimed that it could not find init, and
-dropped to the rescue shell.
-
-However, init was there just fine in /newroot (as before).
-
-I dug out the command that is actually run inside linuxrc,
-
- elif ! chroot "${CHROOT}" test -x /${init#/} 1>/dev/null 2>&1
-
-and tried to run that manually, which led to a rather strange error message
-
-rescueshell / # chroot /newroot test -x /lib/systemd/systemd
-chroot: can't execute 'test': File name too long
-
-Some more research led me to the busybox manpage (where here chroot comes
-from):
-https://busybox.net/downloads/BusyBox.html#chroot
-
-chroot
- chroot NEWROOT [PROG [ARGS]]
- Run PROG with root directory set to NEWROOT
-
-Note, the third argument is *not* a command (as with usual chroot, see the
-manpage from coreutils chroot) but a program!
-
-Bug: https://bugs.gentoo.org/842027
-Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
---- a/defaults/linuxrc
-+++ b/defaults/linuxrc
-@@ -1376,7 +1376,7 @@ do
- if ! mountpoint "${CHROOT}" 1>/dev/null 2>&1
- then
- bad_msg "${CHROOT} is not a mountpoint; Was root device (${REAL_ROOT}) not mounted?"
-- elif ! chroot "${CHROOT}" test -x /${init#/} 1>/dev/null 2>&1
-+ elif ! chroot "${CHROOT}" /usr/bin/test -x /${init#/} 1>/dev/null 2>&1
- then
- mounted_root_device=$(mountpoint -n /newroot 2>/dev/null | awk '{ print $1 }')
- bad_msg "init (${init}) not found in mounted root device (${mounted_root_device})!"
-cgit v1.2.3-18-g5258
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-devicemanager.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-devicemanager.patch
deleted file mode 100644
index f1c5787ed657..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-devicemanager.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 110cffbf0a10a6dabe902eecb9c139663ad737af Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sun, 15 May 2022 12:37:51 -0400
-Subject: [PATCH] gen_initramfs.sh: append devicemanager only for specific
- modules
-
-dmraid
-luks
-lvm
-multipath
-
-Bug: https://bugs.gentoo.org/749957
-Signed-off-by: Mike Gilbert <floppym@gentoo.org>
----
- gen_funcs.sh | 9 +++++++++
- gen_initramfs.sh | 11 +++++++----
- 2 files changed, 16 insertions(+), 4 deletions(-)
-
-diff --git a/gen_funcs.sh b/gen_funcs.sh
-index 500caf2..db396e3 100755
---- a/gen_funcs.sh
-+++ b/gen_funcs.sh
-@@ -22,6 +22,15 @@ isTrue() {
- return 1
- }
-
-+anyTrue() {
-+ local x
-+ for x
-+ do
-+ isTrue "${x}" && return 0
-+ done
-+ return 1
-+}
-+
- set_color_vars() {
- if ! isTrue "${NOCOLOR}"
- then
-diff --git a/gen_initramfs.sh b/gen_initramfs.sh
-index 4ec296e..0b74f4c 100755
---- a/gen_initramfs.sh
-+++ b/gen_initramfs.sh
-@@ -2007,11 +2007,14 @@ append_auxiliary() {
- }
-
- append_data() {
-- local name=$1 var=$2
-+ [ $# -eq 0 ] && gen_die "append_data() called with zero arguments"
-+
-+ local name=$1
- local func="append_${name}"
-
-- [ $# -eq 0 ] && gen_die "append_data() called with zero arguments"
-- if [ $# -eq 1 ] || isTrue "${var}"
-+ shift
-+
-+ if [ $# -eq 0 ] || anyTrue "$@"
- then
- print_info 1 "$(get_indent 1)>> Appending ${name} cpio data ..."
- ${func} || gen_die "${func}() failed!"
-@@ -2037,7 +2040,7 @@ create_initramfs() {
- append_data 'base_layout'
- append_data 'util-linux'
- append_data 'eudev'
-- append_data 'devicemanager'
-+ append_data 'devicemanager' "${DMRAID}" "${LVM}" "${LUKS}" "${MULTIPATH}"
- append_data 'auxiliary' "${BUSYBOX}"
- append_data 'busybox' "${BUSYBOX}"
- append_data 'b2sum' "${B2SUM}"
---
-2.35.1
-
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-fix-btrfs-progs-deps.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-fix-btrfs-progs-deps.patch
deleted file mode 100644
index f9306d851d33..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-fix-btrfs-progs-deps.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-commit 779376e0a1e3c55a8bdc40c5e55ce9bb50ee8eae
-Author: Thomas Deutschmann <whissi@gentoo.org>
-AuthorDate: Tue Nov 16 18:33:12 2021 +0100
-Commit: Thomas Deutschmann <whissi@gentoo.org>
-CommitDate: Tue Nov 16 18:33:12 2021 +0100
-
- btrfs-progs-5.15+ needs libudev
-
- Fixes: d3ee3d06 ("Bump btrfs-progs to v5.15")
- Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-
-diff --git a/defaults/software.sh b/defaults/software.sh
-index 9f64ab0..ec2bacb 100644
---- a/defaults/software.sh
-+++ b/defaults/software.sh
-@@ -32,7 +32,7 @@ GKPKG_BOOST_BUILD_BINPKG="${GKPKG_BOOST_BUILD_BINPKG:-%%CACHE%%/boost-build-${GK
-
- GKPKG_BTRFS_PROGS_PN="btrfs-progs"
- GKPKG_BTRFS_PROGS_PV="${GKPKG_BTRFS_PROGS_PV:-VERSION_BTRFS_PROGS}"
--GKPKG_BTRFS_PROGS_DEPS="util-linux zlib zstd lzo"
-+GKPKG_BTRFS_PROGS_DEPS="util-linux zlib zstd lzo eudev"
- GKPKG_BTRFS_PROGS_SRCTAR="${GKPKG_BTRFS_PROGS_SRCTAR:-${DISTDIR}/btrfs-progs-v${GKPKG_BTRFS_PROGS_PV}.tar.xz}"
- GKPKG_BTRFS_PROGS_SRCDIR="${GKPKG_BTRFS_PROGS_SRCDIR:-btrfs-progs-v${GKPKG_BTRFS_PROGS_PV}}"
- GKPKG_BTRFS_PROGS_BINPKG="${GKPKG_BTRFS_PROGS_BINPKG:-%%CACHE%%/btrfs-progs-${GKPKG_BTRFS_PROGS_PV}-%%ARCH%%.tar.xz}"
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-fuse-glibc-2.34.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-fuse-glibc-2.34.patch
deleted file mode 100644
index 731f127a6712..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-fuse-glibc-2.34.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-commit 1b1da7527b0307cb70118caf5dfe2da778671588
-Author: Thomas Deutschmann <whissi@gentoo.org>
-AuthorDate: Fri Dec 10 01:56:20 2021 +0100
-Commit: Thomas Deutschmann <whissi@gentoo.org>
-CommitDate: Fri Dec 10 01:56:20 2021 +0100
-
- fuse: Add patch to allow building against glibc-2.34
-
- Bug: https://bugs.gentoo.org/828445
- Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-
-diff --git a/patches/fuse/2.9.9/fuse-2.9.9-glibc-2.34.patch b/patches/fuse/2.9.9/fuse-2.9.9-glibc-2.34.patch
-new file mode 100644
-index 0000000..eb7737c
---- /dev/null
-+++ b/patches/fuse/2.9.9/fuse-2.9.9-glibc-2.34.patch
-@@ -0,0 +1,60 @@
-+From 5a43d0f724c56f8836f3f92411e0de1b5f82db32 Mon Sep 17 00:00:00 2001
-+From: Sam James <sam@gentoo.org>
-+Date: Sat, 24 Jul 2021 22:02:45 +0100
-+Subject: [PATCH] util/ulockmgr_server.c: conditionally define closefrom (fix
-+ glibc-2.34+)
-+
-+closefrom(3) has joined us in glibc-land from *BSD and Solaris. Since
-+it's available in glibc 2.34+, we want to detect it and only define our
-+fallback if the libc doesn't provide it.
-+
-+Bug: https://bugs.gentoo.org/803923
-+Signed-off-by: Sam James <sam@gentoo.org>
-+---
-+ configure.ac | 1 +
-+ util/ulockmgr_server.c | 6 ++++++
-+ 2 files changed, 7 insertions(+)
-+
-+diff --git a/configure.ac b/configure.ac
-+index 9946a0efa..a2d481aa9 100644
-+--- a/configure.ac
-++++ b/configure.ac
-+@@ -55,6 +55,7 @@ fi
-+
-+ AC_CHECK_FUNCS([fork setxattr fdatasync splice vmsplice utimensat])
-+ AC_CHECK_FUNCS([posix_fallocate])
-++AC_CHECK_FUNCS([closefrom])
-+ AC_CHECK_MEMBERS([struct stat.st_atim])
-+ AC_CHECK_MEMBERS([struct stat.st_atimespec])
-+
-+diff --git a/util/ulockmgr_server.c b/util/ulockmgr_server.c
-+index 273c7d923..a04dac5c6 100644
-+--- a/util/ulockmgr_server.c
-++++ b/util/ulockmgr_server.c
-+@@ -22,6 +22,10 @@
-+ #include <sys/socket.h>
-+ #include <sys/wait.h>
-+
-++#ifdef HAVE_CONFIG_H
-++ #include "config.h"
-++#endif
-++
-+ struct message {
-+ unsigned intr : 1;
-+ unsigned nofd : 1;
-+@@ -124,6 +128,7 @@ static int receive_message(int sock, void *buf, size_t buflen, int *fdp,
-+ return res;
-+ }
-+
-++#if !defined(HAVE_CLOSEFROM)
-+ static int closefrom(int minfd)
-+ {
-+ DIR *dir = opendir("/proc/self/fd");
-+@@ -141,6 +146,7 @@ static int closefrom(int minfd)
-+ }
-+ return 0;
-+ }
-++#endif
-+
-+ static void send_reply(int cfd, struct message *msg)
-+ {
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-gcc-12-boost-1.79.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-gcc-12-boost-1.79.patch
deleted file mode 100644
index f65a272b953f..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-gcc-12-boost-1.79.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 8b7422293dcf9cc62518dcbc49239b6e637b6b74 Mon Sep 17 00:00:00 2001
-From: "Robin H. Johnson" <robbat2@gentoo.org>
-Date: Sun, 3 Jul 2022 21:46:21 -0700
-Subject: [PATCH] gkbuilds/boost-build.gkbuild: upstream boost flags changed
-
-Upstream boost changed the flags to use 'off' instead of 'none'.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-Closes: https://bugs.gentoo.org/854480
----
- gkbuilds/boost-build.gkbuild | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gkbuilds/boost-build.gkbuild b/gkbuilds/boost-build.gkbuild
-index 03d1f88..0e06ba7 100644
---- a/gkbuilds/boost-build.gkbuild
-+++ b/gkbuilds/boost-build.gkbuild
-@@ -53,6 +53,6 @@ src_install() {
- find "${D}/usr/share/boost-build" -iname "*.py" -delete \
- || die "Failed to remove python files"
-
-- echo 'variant gentoorelease : release : <optimization>none <debug-symbols>none <runtime-link>shared ;' > "${D}/usr/share/boost-build/site-config.jam" \
-+ echo 'variant gentoorelease : release : <optimization>off <debug-symbols>off <runtime-link>shared ;' > "${D}/usr/share/boost-build/site-config.jam" \
- || die "Failed to create '${D}/usr/share/boost-build/site-config.jam'!"
- }
---
-2.35.1
-
diff --git a/sys-kernel/genkernel/files/genkernel-4.2.6-slibtool.patch b/sys-kernel/genkernel/files/genkernel-4.2.6-slibtool.patch
deleted file mode 100644
index 0f0bd2619ae2..000000000000
--- a/sys-kernel/genkernel/files/genkernel-4.2.6-slibtool.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-Bug: https://bugs.gentoo.org/836012
-Upstream-PR: https://github.com/gentoo/genkernel/pull/33
-
-From 1bb3cc10d51026ad500bc9cec883f1f2f0c445ec Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Sun, 15 May 2022 15:49:21 -0700
-Subject: [PATCH 1/3] gen_funcs: Add an install_exe function
-
-This helps when the build uses slibtool where the compiled binary output
-path differs from GNU libtool.
-
-Signed-off-by: orbea <orbea@riseup.net>
----
- gen_funcs.sh | 23 +++++++++++++++++++++++
- 1 file changed, 23 insertions(+)
-
-diff --git a/gen_funcs.sh b/gen_funcs.sh
-index 500caf2d..a4dc0e44 100755
---- a/gen_funcs.sh
-+++ b/gen_funcs.sh
-@@ -1974,6 +1974,29 @@ check_distfiles() {
- fi
- }
-
-+# @FUNCTION: install_exe
-+# @USAGE: <file> <destination>
-+# @DESCRIPTION:
-+# Finds an executable binary file and installs it in cases where there may be
-+# similarly named shell wrapper scripts. This happens when GNU libtool creates
-+# an executable named 'foo' while slibtool creates '.libs/foo' and 'foo' is a
-+# shell script that should not be installed.
-+install_exe() {
-+ local file="${1##*/}"
-+ local dest="${2}"
-+
-+ local dir
-+ [[ "${1%/*}" == "${file}" ]] || dir="${1%/*}/"
-+
-+ [[ -f "${dir}${file}" ]] || gen_die "File '${dir}${file}' does not exist!"
-+
-+ # Ensure only the binaries are installed and not a similarly named wrapper script
-+ find "${S}/${dir}" -type f -name "${file}" -print0 |
-+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
-+ xargs -I '{}' cp -a '{}' "${dest}" ||
-+ gen_die "Failed to copy '${S}/${dir}${file}' to '${dest}'!"
-+}
-+
- # @FUNCTION: expand_file
- # @USAGE: <file>
- # @DESCRIPTION:
-
-From cfc9ff455e2473e4322bd18c5fa21370d9c0702e Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Thu, 24 Mar 2022 11:43:40 -0700
-Subject: [PATCH 2/3] gkbuild/util-linux: Install the correct binaries with
- slibtool
-
-Signed-off-by: orbea <orbea@riseup.net>
----
- gkbuilds/util-linux.gkbuild | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/gkbuilds/util-linux.gkbuild b/gkbuilds/util-linux.gkbuild
-index 40ea1fbb..5addbb1d 100644
---- a/gkbuilds/util-linux.gkbuild
-+++ b/gkbuilds/util-linux.gkbuild
-@@ -47,11 +47,8 @@ src_install() {
-
- mkdir "${D}"/sbin || die "Failed to create '${D}/sbin'!"
-
-- cp -a blkid.static "${D}"/sbin/blkid \
-- || die "Failed to copy '${S}/blkid.static' to '${D}/sbin/blkid'!"
--
-- cp -a switch_root "${D}"/sbin/switch_root \
-- || die "Failed to copy '${S}/switch_root' to '${D}/sbin/switch_root'!"
-+ install_exe 'blkid.static' "${D}"/sbin/blkid
-+ install_exe 'switch_root' "${D}"/sbin/switch_root
-
- local sbin
- for sbin in \
-
-From 2d2e91f288679e272f731917feb58f3768ea586d Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Thu, 24 Mar 2022 13:17:07 -0700
-Subject: [PATCH 3/3] gkbuild/cryptsetup: Install the correct binaries with
- slibtool
-
-Signed-off-by: orbea <orbea@riseup.net>
----
- gkbuilds/cryptsetup.gkbuild | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/gkbuilds/cryptsetup.gkbuild b/gkbuilds/cryptsetup.gkbuild
-index 007874d1..816df609 100644
---- a/gkbuilds/cryptsetup.gkbuild
-+++ b/gkbuilds/cryptsetup.gkbuild
-@@ -34,8 +34,7 @@ src_install() {
- "${D}"/sbin/* \
- "${D}"/usr/share/
-
-- cp -a cryptsetup.static "${D}"/sbin/cryptsetup \
-- || die "Failed to copy '${S}/cryptsetup.static' to '${D}/sbin/cryptsetup'!"
-+ install_exe 'cryptsetup.static' "${D}"/sbin/cryptsetup
-
- "${STRIP}" --strip-all "${D}"/sbin/cryptsetup \
- || die "Failed to strip '${D}/sbin/cryptsetup'!"