summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-docs')
-rw-r--r--sys-kernel/linux-docs/Manifest4
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.1.ebuild64
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.19.ebuild31
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.4.ebuild64
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.9.ebuild64
-rw-r--r--sys-kernel/linux-docs/metadata.xml3
6 files changed, 32 insertions, 198 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index e5d38f18a363..0c4fb3f77e20 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -1,3 +1 @@
-DIST linux-4.1.tar.xz 83017828 BLAKE2B d1dc4e458db191f16306b3d2d7eb60ef5e04307406c769cccdd88beb407f8de228ab1f095a44d6e992b06d01cd896fda31dec1cdf16667f4ca0b628da594aee3 SHA512 168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0
-DIST linux-4.4.tar.xz 87295988 BLAKE2B f260f1858994f5d481fd078c86e51bddbc958f7c5d1586f60dced772e1b1107ecf3aae0558c3e6f39c36f7d3aa1e6cd1e5c64ec9d6f2218f47b98413da6466fb SHA512 13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e
-DIST linux-4.9.tar.xz 93192404 BLAKE2B 83ae310b17d47f1f18d6d28537c31e10f3e60458c5954c4611158ca99e71cc0da2e051272eabf27d5887df4a7cb4a5dd66ff993077c11d2221e92d300a0b48d7 SHA512 bf67ff812cc3cb7e5059e82cc5db0d9a7c5637f7ed9a42e4730c715bf7047c81ed3a571225f92a33ef0b6d65f35595bc32d773356646df2627da55e9bc7f1f1a
+DIST linux-4.19.tar.xz 103117552 BLAKE2B 1dbf16cf410867412d17568fe42bc1e90c034183b654d270b650621ff7664a321950943d0639205bc1ee7ef6210be170c1f2c785a042ed8a4ec5e3a486d890e0 SHA512 ab67cc746b375a8b135e8b23e35e1d6787930d19b3c26b2679787d62951cbdbc3bb66f8ededeb9b890e5008b2459397f9018f1a6772fdef67780b06a4cb9f6f4
diff --git a/sys-kernel/linux-docs/linux-docs-4.1.ebuild b/sys-kernel/linux-docs/linux-docs-4.1.ebuild
deleted file mode 100644
index 510172296876..000000000000
--- a/sys-kernel/linux-docs/linux-docs-4.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit toolchain-funcs
-
-MY_P=linux-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Developer documentation generated from the Linux kernel"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-IUSE="html"
-DEPEND="app-text/docbook-sgml-utils
- app-text/xmlto
- sys-apps/sed
- ~app-text/docbook-xml-dtd-4.1.2"
-RDEPEND=""
-
-src_prepare() {
-
- sed -i \
- -e "s:db2:docbook2:g" \
- -e "s:/usr/local/man:${D}/usr/share/man:g" \
- "${S}"/Documentation/DocBook/Makefile
-
- # fix for parallel build as per bug #248337
- sed -i \
- -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
- "${S}"/Makefile
-}
-
-src_compile() {
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- emake mandocs || die "make mandocs failed"
-
- if use html; then
- emake htmldocs || die "make htmldocs failed"
- fi
-}
-
-src_install() {
- local file
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- make installmandocs || die "make installmandocs failed"
-
- if use html; then
- # There is no subdirectory named "index"
- dohtml Documentation/DocBook/index.html
- rm Documentation/DocBook/index.html
- for file in Documentation/DocBook/*.html; do
- dohtml -r ${file/\.html/}
- done
- fi
-}
diff --git a/sys-kernel/linux-docs/linux-docs-4.19.ebuild b/sys-kernel/linux-docs/linux-docs-4.19.ebuild
new file mode 100644
index 000000000000..34100b0f0626
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-4.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE=""
+DEPEND="dev-python/sphinx"
+RDEPEND=""
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+ emake htmldocs || die "make htmldocs failed"
+}
+
+src_install() {
+ HTML_DOCS=( Documentation/output/. )
+ einstalldocs
+}
diff --git a/sys-kernel/linux-docs/linux-docs-4.4.ebuild b/sys-kernel/linux-docs/linux-docs-4.4.ebuild
deleted file mode 100644
index 510172296876..000000000000
--- a/sys-kernel/linux-docs/linux-docs-4.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit toolchain-funcs
-
-MY_P=linux-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Developer documentation generated from the Linux kernel"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-IUSE="html"
-DEPEND="app-text/docbook-sgml-utils
- app-text/xmlto
- sys-apps/sed
- ~app-text/docbook-xml-dtd-4.1.2"
-RDEPEND=""
-
-src_prepare() {
-
- sed -i \
- -e "s:db2:docbook2:g" \
- -e "s:/usr/local/man:${D}/usr/share/man:g" \
- "${S}"/Documentation/DocBook/Makefile
-
- # fix for parallel build as per bug #248337
- sed -i \
- -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
- "${S}"/Makefile
-}
-
-src_compile() {
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- emake mandocs || die "make mandocs failed"
-
- if use html; then
- emake htmldocs || die "make htmldocs failed"
- fi
-}
-
-src_install() {
- local file
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- make installmandocs || die "make installmandocs failed"
-
- if use html; then
- # There is no subdirectory named "index"
- dohtml Documentation/DocBook/index.html
- rm Documentation/DocBook/index.html
- for file in Documentation/DocBook/*.html; do
- dohtml -r ${file/\.html/}
- done
- fi
-}
diff --git a/sys-kernel/linux-docs/linux-docs-4.9.ebuild b/sys-kernel/linux-docs/linux-docs-4.9.ebuild
deleted file mode 100644
index 510172296876..000000000000
--- a/sys-kernel/linux-docs/linux-docs-4.9.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit toolchain-funcs
-
-MY_P=linux-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Developer documentation generated from the Linux kernel"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-IUSE="html"
-DEPEND="app-text/docbook-sgml-utils
- app-text/xmlto
- sys-apps/sed
- ~app-text/docbook-xml-dtd-4.1.2"
-RDEPEND=""
-
-src_prepare() {
-
- sed -i \
- -e "s:db2:docbook2:g" \
- -e "s:/usr/local/man:${D}/usr/share/man:g" \
- "${S}"/Documentation/DocBook/Makefile
-
- # fix for parallel build as per bug #248337
- sed -i \
- -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
- "${S}"/Makefile
-}
-
-src_compile() {
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- emake mandocs || die "make mandocs failed"
-
- if use html; then
- emake htmldocs || die "make htmldocs failed"
- fi
-}
-
-src_install() {
- local file
- local ARCH=$(tc-arch-kernel)
- unset KBUILD_OUTPUT
-
- make installmandocs || die "make installmandocs failed"
-
- if use html; then
- # There is no subdirectory named "index"
- dohtml Documentation/DocBook/index.html
- rm Documentation/DocBook/index.html
- for file in Documentation/DocBook/*.html; do
- dohtml -r ${file/\.html/}
- done
- fi
-}
diff --git a/sys-kernel/linux-docs/metadata.xml b/sys-kernel/linux-docs/metadata.xml
index 029e49742263..8c8d3c0814eb 100644
--- a/sys-kernel/linux-docs/metadata.xml
+++ b/sys-kernel/linux-docs/metadata.xml
@@ -4,7 +4,4 @@
<maintainer type="person">
<email>mpagano@gentoo.org</email>
</maintainer>
- <use>
- <flag name="html">Install HTML documentation</flag>
- </use>
</pkgmetadata>