summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/rsbac-sources/rsbac-sources-3.10.7.ebuild')
-rw-r--r--sys-kernel/rsbac-sources/rsbac-sources-3.10.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-kernel/rsbac-sources/rsbac-sources-3.10.7.ebuild b/sys-kernel/rsbac-sources/rsbac-sources-3.10.7.ebuild
new file mode 100644
index 000000000000..11e93b604098
--- /dev/null
+++ b/sys-kernel/rsbac-sources/rsbac-sources-3.10.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+
+RSBC_VER="1.4.7"
+RSBC_PATCH="patch-linux-${PV}-rsbac-${RSBC_VER}.diff.xz"
+
+HGPV_URI="http://download.rsbac.org/patches/${RSBC_VER}/${RSBC_PATCH}"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${RSBC_PATCH}"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="RSBAC kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"