summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.8_p3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 2e7c19369741..14c376d26285 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -16,3 +16,4 @@ DIST pf-sources-5.7_p5.patch 2473444 BLAKE2B cea4b7f888e2ec76dde07310ab80bacfdc3
DIST pf-sources-5.7_p7.patch 2471776 BLAKE2B c87c9a5f159967877a2858da1af919332aa9ccd49c2029950b31bcce592b9e802c4d5d5daf2f86929bf9318aaa455d879d3eba21904ab38e5615f05742934a98 SHA512 11c0f0021c1d67f65461a74598ed355309c5bdea8d8c94a8e59bcdff2a8320f9504a4457dd8adddcbfc85cd753bff6018ab9a093cfd7d70dcfee4a2f82110d30
DIST pf-sources-5.8_p1.patch 176978 BLAKE2B 80be84087ed65f0de42f9e70ac2002bcd77dfa756a769388ffcdd559aa5a7b0280725fa0ddb590cce90825beeeb55939a714f510e723cd8b0ff8ec400cd805ef SHA512 4ec9d5990f0a25666198b6be26bed0c87e5ce3fb3541c03d3b853b574ee7c0294c7f7f3c692b469f2519b38f918a214afc2b908c117578a7a4436caf2f3929ab
DIST pf-sources-5.8_p2.patch 1071081 BLAKE2B e6c5f85607b7483ee711bee6b62dae5fc1dc44c85ef9bf107dfc997a31f83258624b748511a5bc8c2f76e3bf120779123187cff4721062c717c4eb713d5416e9 SHA512 df3c6da9e0700af7d6126af5831fa6d9a06594a31520f3dcddd098862606262cb139c8e513ffcbe1c8c4ee8e60bb3d6c4a0f505f806e02a9b779410656d4cc2a
+DIST pf-sources-5.8_p3.patch 1248429 BLAKE2B acf0911cd8b9c356bcafe754e54e982a6f749800c01795fa9ca4573a932e366185378e41a649150718ddf604e787ba85d22bec134d106c2fb44aa35262a32d19 SHA512 01cb5fd69560220c61106508585db4970164dc27b373aee03b5b9a14a30af5b04534095b9f839228f5a9bf4139f8d6e0b8b978ca2ae1b6c1e873cce782c7e9c7
diff --git a/sys-kernel/pf-sources/pf-sources-5.8_p3.ebuild b/sys-kernel/pf-sources/pf-sources-5.8_p3.ebuild
new file mode 100644
index 000000000000..2a683a5287d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.8_p3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}