summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild b/sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild
index 364ccbcca438..75ff3c155c03 100644
--- a/sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-18.1.0_rc2.ebuild
@@ -4,7 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake crossdev flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake crossdev flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -44,13 +45,6 @@ pkg_pretend() {
}
pkg_setup() {
- # Darwin Prefix builds do not have llvm installed yet, so rely on
- # bootstrap-prefix to set the appropriate path vars to LLVM instead
- # of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
-
if target_is_not_host || tc-is-cross-compiler ; then
# strips vars like CFLAGS="-march=x86_64-v3" for non-x86 architectures
CHOST=${CTARGET} strip-unsupported-flags
@@ -67,6 +61,8 @@ test_compiler() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"