summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild')
-rw-r--r--sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild b/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild
index d816d53c4048..b5e23331c74e 100644
--- a/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild
+++ b/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Standalone fts library for use with musl"
HOMEPAGE="https://github.com/pullmoll/musl-fts"
SRC_URI="https://github.com/pullmoll/musl-fts/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/musl-fts-${PV}"
LICENSE="BSD"
SLOT="0"
@@ -18,8 +19,6 @@ DEPEND="
!sys-libs/glibc
!sys-libs/uclibc"
-S="${WORKDIR}/musl-fts-${PV}"
-
src_prepare() {
default
eautoreconf
@@ -32,6 +31,6 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
mv "${ED%/}"/usr/$(get_libdir)/pkgconfig/{musl-fts,fts-standalone}.pc || die
}