summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.26-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.26-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.26-r1.ebuild b/sys-libs/glibc/glibc-2.26-r1.ebuild
index fbe7444f9488..b852aba96bc6 100644
--- a/sys-libs/glibc/glibc-2.26-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.26-r1.ebuild
@@ -315,7 +315,19 @@ glibc_do_configure() {
[[ -d ports ]] && addons+=",ports"
popd > /dev/null
- myconf+=( --enable-stack-protector=all )
+ case ${CTARGET} in
+ powerpc-*)
+ # Currently gcc on powerpc32 generates invalid code for
+ # __builtin_return_address(0) calls. Normally programs
+ # don't do that but malloc hooks in glibc do:
+ # https://gcc.gnu.org/PR81996
+ # https://bugs.gentoo.org/629054
+ myconf+=( --enable-stack-protector=no )
+ ;;
+ *)
+ myconf+=( --enable-stack-protector=all )
+ ;;
+ esac
myconf+=( --enable-stackguard-randomization )
[[ $(tc-is-softfloat) == "yes" ]] && myconf+=( --without-fp )