summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index ce5ad8d3c43d..d62fe8108de1 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1540,6 +1540,12 @@ pkg_postinst() {
use compile-locales || run_locale_gen "${EROOT}/"
fi
+ if systemd_is_booted && [[ -z ${ROOT} ]] ; then
+ # We need to restart systemd when upgrading from < 2.34
+ # bug #823756
+ systemctl daemon-reexec
+ fi
+
# Check for sanity of /etc/nsswitch.conf, take 2
if [[ -e ${EROOT}/etc/nsswitch.conf ]] && ! has_version sys-auth/libnss-nis ; then
local entry