summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcap/files')
-rw-r--r--sys-libs/libcap/files/libcap-2.61-Wformat.patch25
-rw-r--r--sys-libs/libcap/files/libcap-2.61-ignore-RAISE_SETFCAP-install-failures.patch24
-rw-r--r--sys-libs/libcap/files/libcap-2.61-no_perl.patch57
3 files changed, 0 insertions, 106 deletions
diff --git a/sys-libs/libcap/files/libcap-2.61-Wformat.patch b/sys-libs/libcap/files/libcap-2.61-Wformat.patch
deleted file mode 100644
index e0046de58770..000000000000
--- a/sys-libs/libcap/files/libcap-2.61-Wformat.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9fd3e7ac5870f84c73ac777d9a14480227ad7f00 Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Sun, 28 Nov 2021 14:14:42 +0100
-Subject: [PATCH] Fix `-Wformat` on 32-bit platforms
-
----
- libcap/cap_test.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libcap/cap_test.c b/libcap/cap_test.c
-index b7fb2c5..39df261 100644
---- a/libcap/cap_test.c
-+++ b/libcap/cap_test.c
-@@ -124,7 +124,7 @@ static int test_short_bits(void)
- }
- if (strlen(tmp) > __CAP_NAME_SIZE) {
- printf("cap_to_text buffer size reservation needs fixing (%ld > %d)\n",
-- strlen(tmp), __CAP_NAME_SIZE);
-+ (long int)strlen(tmp), __CAP_NAME_SIZE);
- result = -1;
- }
- free(tmp);
---
-2.34.1
-
diff --git a/sys-libs/libcap/files/libcap-2.61-ignore-RAISE_SETFCAP-install-failures.patch b/sys-libs/libcap/files/libcap-2.61-ignore-RAISE_SETFCAP-install-failures.patch
deleted file mode 100644
index 25f853b2a982..000000000000
--- a/sys-libs/libcap/files/libcap-2.61-ignore-RAISE_SETFCAP-install-failures.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 8dfcdcfdcb9c462a05566aa8d3c6eca871f0ddbf Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 10 Feb 2016 09:52:45 +0100
-Subject: [PATCH] ignore RAISE_SETFCAP install failures
-
-While the new RAISE_SETFCAP feature is nifty, its failure to run (often
-due to the fs not supporting it) shouldn't impair the default install.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-
-Forward ported from libcap-2.20 to libcap-2.25
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---- a/progs/Makefile
-+++ b/progs/Makefile
-@@ -39,7 +39,7 @@
- install -m 0755 $$p $(FAKEROOT)$(SBINDIR) ; \
- done
- ifeq ($(RAISE_SETFCAP),yes)
-- $(FAKEROOT)$(SBINDIR)/setcap cap_setfcap=i $(FAKEROOT)$(SBINDIR)/setcap
-+ -$(FAKEROOT)$(SBINDIR)/setcap cap_setfcap=i $(FAKEROOT)$(SBINDIR)/setcap
- endif
-
- test:
diff --git a/sys-libs/libcap/files/libcap-2.61-no_perl.patch b/sys-libs/libcap/files/libcap-2.61-no_perl.patch
deleted file mode 100644
index 3d42a4dc6135..000000000000
--- a/sys-libs/libcap/files/libcap-2.61-no_perl.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 3f76418eaf73896489129c529fac021e4f3a03c0 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 21 Nov 2018 11:00:54 +0100
-Subject: [PATCH] use awk/sed instead of perl for creating header files
-
-More systems should have awk/sed than perl.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-
-Forward ported from libcap-2.22 to libcap-2.26
-and incorporated the gperf-3.1 fix provided by Mike Gilbert
-<floppym@gentoo.org>
-Forward ported from libcap-2.26 to libcap-2.28
-Forward ported from libcap-2.28 to libcap-2.38
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---- a/libcap/Makefile
-+++ b/libcap/Makefile
-@@ -20,6 +20,8 @@
-
- # Always build libcap sources this way:
- CFLAGS += -fPIC
-+AWK = awk
-+SED = sed
-
- # The linker magic needed to build a dynamic library as independently
- # executable
-@@ -82,8 +84,18 @@
- ./_makenames > cap_names.h
-
- $(GPERF_OUTPUT): cap_names.list.h
-- perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%{\nconst struct __cap_token_s *__cap_lookup_name(const char *, size_t);\n%}\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
-- sed -e 's/unsigned int len/size_t len/' -i $@
-+ (printf "%b" "struct __cap_token_s { const char *name; int index; };\n%%\n"; \
-+ $(SED) -e 's:["{}]::g' -e 's:,$$::' $<) | \
-+ gperf \
-+ --ignore-case \
-+ --language=ANSI-C \
-+ --includes \
-+ --readonly \
-+ --null-strings \
-+ --global-table \
-+ --hash-function-name=__cap_hash_name \
-+ --lookup-function-name="__cap_lookup_name" \
-+ -c -t -m20 $(INDENT) > $@
-
- # Intention is that libcap keeps up with torvalds' tree, as reflected
- # by this maintained version of the kernel header. libcap dynamically
-@@ -92,7 +104,7 @@
- UAPI_HEADER := $(topdir)/libcap/include/uapi/linux/capability.h
- cap_names.list.h: Makefile $(UAPI_HEADER)
- @echo "=> making $@ from $(UAPI_HEADER)"
-- perl -e 'while ($$l=<>) { if ($$l =~ /^\#define[ \t](CAP[_A-Z]+)[ \t]+([0-9]+)\s+$$/) { $$tok=$$1; $$val=$$2; $$tok =~ tr/A-Z/a-z/; print "{\"$$tok\",$$val},\n"; } }' $(UAPI_HEADER) | fgrep -v 0x > $@
-+ $(AWK) '($$0 ~ /^#define[[:space:]]+CAP[_A-Z]+[[:space:]]+[0-9]+[[:space:]]*$$/) { printf "{\"%s\",%s},\n", tolower($$2), $$3 }' $(UAPI_HEADER) > $@
-
- $(STACAPLIBNAME): $(CAPOBJS)
- $(AR) rcs $@ $^