summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libomp/libomp-5.0.0.ebuild')
-rw-r--r--sys-libs/libomp/libomp-5.0.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-libs/libomp/libomp-5.0.0.ebuild b/sys-libs/libomp/libomp-5.0.0.ebuild
index f90baa29e665..87c3bfe493f6 100644
--- a/sys-libs/libomp/libomp-5.0.0.ebuild
+++ b/sys-libs/libomp/libomp-5.0.0.ebuild
@@ -8,7 +8,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-multilib python-any-r1
+inherit cmake-multilib linux-info python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -22,8 +22,7 @@ LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="hwloc ompt test"
-# Restrict tests to avoid hanging, https://bugs.gentoo.org/638410
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND="hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )"
# tests:
@@ -43,11 +42,19 @@ S=${WORKDIR}/openmp-${PV/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+CONFIG_CHECK="~!SCHED_PDS"
+ERROR_SCHED_PDS="PDS scheduler is not supported as it does not implement sched_yield()"
+
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
pkg_setup() {
+ linux-info_pkg_setup
use test && python-any-r1_pkg_setup
}