summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libraw1394/libraw1394-2.0.8.ebuild')
-rw-r--r--sys-libs/libraw1394/libraw1394-2.0.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-libs/libraw1394/libraw1394-2.0.8.ebuild b/sys-libs/libraw1394/libraw1394-2.0.8.ebuild
new file mode 100644
index 000000000000..f09d6677e867
--- /dev/null
+++ b/sys-libs/libraw1394/libraw1394-2.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="library that provides direct access to the IEEE 1394 bus"
+HOMEPAGE="http://ieee1394.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="app-arch/xz-utils"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ --without-fw-dir \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}