summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libservicelog/libservicelog-1.1.18.ebuild')
-rw-r--r--sys-libs/libservicelog/libservicelog-1.1.18.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/libservicelog/libservicelog-1.1.18.ebuild b/sys-libs/libservicelog/libservicelog-1.1.18.ebuild
new file mode 100644
index 000000000000..d5fece7827ce
--- /dev/null
+++ b/sys-libs/libservicelog/libservicelog-1.1.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Provides a library for logging service-related events"
+SRC_URI="mirror://sourceforge/linux-diag/${P}.tar.gz"
+HOMEPAGE="http://linux-diag.sourceforge.net/servicelog/"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ dev-db/sqlite:=
+ sys-libs/librtas
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/logger
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}