summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libservicelog/libservicelog-1.1.19.ebuild')
-rw-r--r--sys-libs/libservicelog/libservicelog-1.1.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-libs/libservicelog/libservicelog-1.1.19.ebuild b/sys-libs/libservicelog/libservicelog-1.1.19.ebuild
new file mode 100644
index 000000000000..8d3fc3d75d9c
--- /dev/null
+++ b/sys-libs/libservicelog/libservicelog-1.1.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Provides a library for logging service-related events"
+SRC_URI="https://github.com/power-ras/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/power-ras/libservicelog"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ dev-db/sqlite:=
+ sys-libs/librtas
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/logger
+"
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ local DOCS=( ChangeLog README )
+ default
+ find "${D}" -name '*.la' -delete || die
+}