summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libvpd')
-rw-r--r--sys-libs/libvpd/Manifest2
-rw-r--r--sys-libs/libvpd/files/2.2.8-gcc11.patch84
-rw-r--r--sys-libs/libvpd/files/2.2.8-warnings.patch52
-rw-r--r--sys-libs/libvpd/libvpd-2.2.9.ebuild (renamed from sys-libs/libvpd/libvpd-2.2.8-r1.ebuild)11
-rw-r--r--sys-libs/libvpd/metadata.xml5
5 files changed, 7 insertions, 147 deletions
diff --git a/sys-libs/libvpd/Manifest b/sys-libs/libvpd/Manifest
index 908a68bb41b4..3e825ef8afde 100644
--- a/sys-libs/libvpd/Manifest
+++ b/sys-libs/libvpd/Manifest
@@ -1 +1 @@
-DIST libvpd-2.2.8.tar.gz 52725 BLAKE2B 76bdc6ddf80236a6848185273c2cac181d44214f0c609d7c5af6fa4d09a7cd816324af35745617ce3daa7268311e2ed754335600df1d4970a324eb327015d051 SHA512 d0b7d1760c6ae54717c538405c651317b7318dec5780961f5386c09b7d245e35a84c2fc47d89c47c3cd2168d73d7186f5819981d52c3ba962514639833dc62aa
+DIST libvpd-2.2.9.tar.gz 53747 BLAKE2B c8898e2f604431b74bf5e10fc99e7a9b5540b825f2a996776109a2b2b636f732ff8d9f7956ffea1231e5b023e285eee641a873a68fcd8a2d6a6d9e64c5ab3b18 SHA512 e32a80e0f3aaedbaaac64dbdedfee7eeb2e7a7b6d2d737bca4678d26caadab77032a7c26211a5fc3caed3724488bc8fa99620ceac05f8d156ca90f4452cfaf0a
diff --git a/sys-libs/libvpd/files/2.2.8-gcc11.patch b/sys-libs/libvpd/files/2.2.8-gcc11.patch
deleted file mode 100644
index 7e09f8329bba..000000000000
--- a/sys-libs/libvpd/files/2.2.8-gcc11.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 83ccb994e30364c0703d7b8c15817d56b42da2e6 Mon Sep 17 00:00:00 2001
-From: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
-Date: Wed, 7 Apr 2021 14:11:41 +0530
-Subject: [PATCH] Remove dynamic exception specification
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Tomasz Kłoczko reported that the build fails, while compiling
-with GCC 11:
-
-In file included from src/vpdretriever.cpp:25:
-./src/libvpd-2/vpdretriever.hpp:62:33: error: ISO C++17 does not allow dynamic exception specifications
- 62 | throw( VpdException& );
- | ^~~~~
-./src/libvpd-2/vpdretriever.hpp:74:33: error: ISO C++17 does not allow dynamic exception specifications
- 74 | throw( VpdException& );
- | ^~~~~
-src/vpdretriever.cpp:50:37: error: ISO C++17 does not allow dynamic exception specifications
- 50 | string dbFileName ) throw( VpdException& )
- | ^~~~~
-src/vpdretriever.cpp:62:39: error: ISO C++17 does not allow dynamic exception specifications
- 62 | VpdRetriever::VpdRetriever( ) throw( VpdException& )
- | ^~~~~
-make: *** [Makefile:660: src/vpdretriever.lo] Error 1
-
-As part of
-http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2016/p0003r5.html,
-the dynamic exception specification have been removed. Remove the
-throw specifier, to specify that the function might throw an exception.
-
-Signed-off-by: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
-Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
----
- src/libvpd-2/vpdretriever.hpp | 6 ++----
- src/vpdretriever.cpp | 4 ++--
- 2 files changed, 4 insertions(+), 6 deletions(-)
-
-diff --git a/src/libvpd-2/vpdretriever.hpp b/src/libvpd-2/vpdretriever.hpp
-index 0d91ac4..1be2664 100644
---- a/src/libvpd-2/vpdretriever.hpp
-+++ b/src/libvpd-2/vpdretriever.hpp
-@@ -58,8 +58,7 @@ namespace lsvpd
- * @param dbFileName
- * The file name for the VPD database.
- */
-- VpdRetriever( string envDir, string dbFileName )
-- throw( VpdException& );
-+ VpdRetriever( string envDir, string dbFileName );
-
- /**
- * Builds A VpdRetriever object that can be used for reading the
-@@ -70,8 +69,7 @@ namespace lsvpd
- * this constructor, there were serious underlying issues that
- * are not recoverable. Uses the default dir and filename
- */
-- VpdRetriever( )
-- throw( VpdException& );
-+ VpdRetriever( );
- ~VpdRetriever( );
-
- /**
-diff --git a/src/vpdretriever.cpp b/src/vpdretriever.cpp
-index 9f7e7a0..470047e 100644
---- a/src/vpdretriever.cpp
-+++ b/src/vpdretriever.cpp
-@@ -47,7 +47,7 @@ namespace lsvpd
- const string VpdRetriever::UDEV_NOTIFY_FILE ( "/run/run.vpdupdate" );
-
- VpdRetriever::VpdRetriever( string envDir,
-- string dbFileName ) throw( VpdException& )
-+ string dbFileName )
- {
- try {
- db = new VpdDbEnv( envDir, dbFileName, true );
-@@ -59,7 +59,7 @@ namespace lsvpd
- }
- }
-
-- VpdRetriever::VpdRetriever( ) throw( VpdException& )
-+ VpdRetriever::VpdRetriever( )
- {
- struct stat vpd_stat,udev_stat;
- const string vpddb = VpdRetriever::DEFAULT_DIR + VpdRetriever::DEFAULT_FILE;
diff --git a/sys-libs/libvpd/files/2.2.8-warnings.patch b/sys-libs/libvpd/files/2.2.8-warnings.patch
deleted file mode 100644
index 1419de3dda49..000000000000
--- a/sys-libs/libvpd/files/2.2.8-warnings.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 72b75e1976b50372f07271a5235ee8e9c75bdac4 Mon Sep 17 00:00:00 2001
-From: Kamalesh Babulal <kamalesh@linux.ibm.com>
-Date: Mon, 21 Jun 2021 11:42:02 +0530
-Subject: [PATCH] vpddbenv_c: fix compile warnings
-
-src/vpddbenv_c.c: In function 'new_vpddbenv':
-src/vpddbenv_c.c:56:17: warning: 'strncat' specified bound 1 equals source length [-Wstringop-overflow=]
- 56 | strncat( ret->fullPath, "/" , 1 );
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-src/vpddbenv_c.c:58:17: warning: 'strncat' accessing between 258 and 9223372036854775804 bytes at offsets 514 and 257 may overlap 1 byte at offset 514 [-Wrestrict]
- 58 | strncat( ret->fullPath, ret->dbFileName, strlen(ret->dbFileName) );
- |
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-While compiling the code with GCC-11 (Fedora 34), the GCC complains
-about src string length and N bytes mentioned in the strncat() are of
-same length. It gets suspicious, when strncat() mimics strcat(), the
-strcat() was replaced using strncat() by the commit 38de4e65205
-("libvpd: Convert strcat to strncat") as part of secure coding.
-
-refactor the code using snprintf(), making the code lean and keep the
-GCC happy as well.
-
-Signed-off-by: Kamalesh Babulal <kamalesh@linux.ibm.com>
-Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
----
- src/vpddbenv_c.c | 12 ++++--------
- 1 file changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/src/vpddbenv_c.c b/src/vpddbenv_c.c
-index 96aecd3..bae36e9 100644
---- a/src/vpddbenv_c.c
-+++ b/src/vpddbenv_c.c
-@@ -50,14 +50,10 @@ struct vpddbenv * new_vpddbenv( const char *dir, const char *file )
- ret->dbFileName[MAX_NAME_LENGTH] = '\0';
- }
-
-- strncpy( ret->fullPath, ret->envDir , FULL_PATH_SIZE - 1);
--
-- if (strlen(ret->fullPath) + 1 < FULL_PATH_SIZE)
-- strncat( ret->fullPath, "/" , 1 );
-- if (strlen(ret->fullPath) + strlen(ret->dbFileName) < FULL_PATH_SIZE)
-- strncat( ret->fullPath, ret->dbFileName, strlen (ret->dbFileName) );
--
-- ret->fullPath[FULL_PATH_SIZE - 1] = '\0';
-+ if ( ( strlen( ret->envDir ) + strlen( ret->dbFileName ) + 1 ) <
-+ FULL_PATH_SIZE )
-+ snprintf( ret->fullPath, FULL_PATH_SIZE,
-+ "%s/%s", ret->envDir, ret->dbFileName );
-
- rc = sqlite3_open( ret->fullPath, &(ret->db) );
- if( rc != SQLITE_OK )
diff --git a/sys-libs/libvpd/libvpd-2.2.8-r1.ebuild b/sys-libs/libvpd/libvpd-2.2.9.ebuild
index 3b69e327edd6..8d0128e92307 100644
--- a/sys-libs/libvpd/libvpd-2.2.8-r1.ebuild
+++ b/sys-libs/libvpd/libvpd-2.2.9.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools udev
DESCRIPTION="Library implementation for listing Vital Product Data"
@@ -9,7 +9,7 @@ HOMEPAGE="https://github.com/power-ras/libvpd"
SRC_URI="https://github.com/power-ras/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
-SLOT="0"
+SLOT="0/3"
KEYWORDS="ppc ppc64"
DEPEND="
@@ -18,11 +18,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/2.2.8-gcc11.patch"
- "${FILESDIR}/2.2.8-warnings.patch"
-)
-
src_prepare() {
default
eautoreconf
diff --git a/sys-libs/libvpd/metadata.xml b/sys-libs/libvpd/metadata.xml
index 2219560b548b..079cdb9aa6f0 100644
--- a/sys-libs/libvpd/metadata.xml
+++ b/sys-libs/libvpd/metadata.xml
@@ -3,9 +3,10 @@
<pkgmetadata>
<maintainer type="project">
<email>ppc@gentoo.org</email>
- <name>Gentoo Linux PowerPC Development</name>
+ <name>PowerPC architecture team</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">linux-diag</remote-id>
+ <remote-id type="github">power-ras/libvpd</remote-id>
+ <changelog>https://github.com/power-ras/libvpd/blob/master/ChangeLog</changelog>
</upstream>
</pkgmetadata>