summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
index b25eb93a2469..fa017859016b 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
@@ -43,13 +43,13 @@ python_check_deps() {
}
pkg_pretend() {
- if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
- die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
- fi
-
if has "distcc" ${FEATURES} ; then
ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
+
+ if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
+ die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
+ fi
fi
}