summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/minizip-ng')
-rw-r--r--sys-libs/minizip-ng/Manifest1
-rw-r--r--sys-libs/minizip-ng/files/minizip-ng-4.0.4-libbsd-overlay.patch16
-rw-r--r--sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild97
3 files changed, 114 insertions, 0 deletions
diff --git a/sys-libs/minizip-ng/Manifest b/sys-libs/minizip-ng/Manifest
index 665aa819f66b..e3b86ae5804a 100644
--- a/sys-libs/minizip-ng/Manifest
+++ b/sys-libs/minizip-ng/Manifest
@@ -1,3 +1,4 @@
DIST minizip-ng-4.0.1.tar.gz 769661 BLAKE2B 30147d8643844d9ea10f3f860d41e5025b2c8a5e3bb197722cf3e9ea3d30f40d78974a437425df660db777d9593db9e39b2293db7733ccfaf50c5eba4982a6fe SHA512 857450c3a51a75269afdffdcbaaa6d05894913dd98a91e307129b5e61766f6e3d20bca5841afa41bbe6ca88ad0666c462079a5e1fe73718c2dffd05219c8f258
DIST minizip-ng-4.0.2.tar.gz 769745 BLAKE2B 7e983169d637e0b94ad6f0c7ceca743fcc54fe1c2f98bae9cb4e9050fe85cb2d46d36cb185d5eb7c0b577d606d9eedfecc3817048b3e7006287fa5e001bed4a5 SHA512 4e626a312c35e5f003e4f365261ef3e1bf33488f8698ec31b1b33d32f6a34ed0b54f0e3ffdae658e5b441532dde3cee45c3822532f52e68ea588e809e8f4081c
DIST minizip-ng-4.0.3.tar.gz 770041 BLAKE2B a5772de8a372738fc1736a5ba307928ebf50ce9de26c845beb0798b2593662a0d990b8ad305238086eea11ad4aba2d7db2a5386d6ca65968bfd40f1fa573e693 SHA512 96d1a5ac1106f737f4db161867a440c272b65c617add30aa0224215abba8098ece9f2bde5c4e407932d0fa5d3ca8696a1db82b5a19ce7ffd8019dba83ab5fd01
+DIST minizip-ng-4.0.4.tar.gz 770202 BLAKE2B 5b9f4a66325de4298db0f7cdb8830050fe55c46c3914f51d7e7c4fe4cd9e080ab9658739dc936da602d67199333b6eca71218ad155244b9c04f50944486a02b1 SHA512 2662ddf90666babe73474f6fc48f5a64f276d555b7a0f04f790b9edef570cb958356e900632c3795fb2053f4813c449240ff101d32b063eca4ad869bef0546fd
diff --git a/sys-libs/minizip-ng/files/minizip-ng-4.0.4-libbsd-overlay.patch b/sys-libs/minizip-ng/files/minizip-ng-4.0.4-libbsd-overlay.patch
new file mode 100644
index 000000000000..2a62f96f1413
--- /dev/null
+++ b/sys-libs/minizip-ng/files/minizip-ng-4.0.4-libbsd-overlay.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/889266
+https://gitlab.freedesktop.org/libbsd/libbsd/-/issues/15
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -538,10 +538,10 @@ else()
+
+ if(HAVE_LIBBSD_ARC4RANDOM_BUF)
+ list(APPEND MINIZIP_DEF -DHAVE_LIBBSD -DHAVE_ARC4RANDOM_BUF)
+- list(APPEND MINIZIP_INC ${LIBBSD_INCLUDE_DIRS})
+ list(APPEND MINIZIP_LIB ${LIBBSD_LIBRARIES})
+ list(APPEND MINIZIP_LBD ${LIBBSD_LIBRARY_DIRS})
+
++ add_compile_options(${LIBBSD_CFLAGS})
+ link_directories(${LIBBSD_LIBRARY_DIRS})
+ endif()
+ else()
diff --git a/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild b/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild
new file mode 100644
index 000000000000..d23ad9d63cb9
--- /dev/null
+++ b/sys-libs/minizip-ng/minizip-ng-4.0.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake-multilib
+
+DESCRIPTION="Fork of the popular zip manipulation library found in the zlib distribution"
+HOMEPAGE="https://github.com/zlib-ng/minizip-ng"
+SRC_URI="https://github.com/zlib-ng/minizip-ng/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="compat openssl test zstd"
+RESTRICT="!test? ( test )"
+
+# Automagically prefers sys-libs/zlib-ng if installed, so let's
+# just depend on it as presumably it's better tested anyway.
+RDEPEND="
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ app-arch/xz-utils
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ sys-libs/zlib-ng[${MULTILIB_USEDEP}]
+ virtual/libiconv
+ compat? ( !sys-libs/zlib[minizip] )
+ openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
+ zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.4-libbsd-overlay.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DMZ_COMPAT=$(usex compat)
+
+ -DMZ_BUILD_TESTS=$(usex test)
+ -DMZ_BUILD_UNIT_TESTS=$(usex test)
+
+ -DMZ_FETCH_LIBS=OFF
+ -DMZ_FORCE_FETCH_LIBS=OFF
+
+ # Compression library options
+ -DMZ_ZLIB=ON
+ -DMZ_BZIP2=ON
+ -DMZ_LZMA=ON
+ -DMZ_ZSTD=$(usex zstd)
+ -DMZ_LIBCOMP=OFF
+
+ # Encryption support options
+ -DMZ_PKCRYPT=ON
+ -DMZ_WZAES=ON
+ -DMZ_OPENSSL=$(usex openssl)
+ -DMZ_LIBBSD=ON
+
+ # Character conversion options
+ -DMZ_ICONV=ON
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ local myctestargs=(
+ # TODO: investigate
+ -E "(raw-unzip-pkcrypt|raw-append-unzip-pkcrypt|raw-erase-unzip-pkcrypt|deflate-unzip-pkcrypt|deflate-append-unzip-pkcrypt|deflate-erase-unzip-pkcrypt|bzip2-unzip-pkcrypt|bzip2-append-unzip-pkcrypt|bzip2-erase-unzip-pkcrypt|lzma-unzip-pkcrypt|lzma-append-unzip-pkcrypt|lzma-erase-unzip-pkcrypt|xz-unzip-pkcrypt|xz-append-unzip-pkcrypt|xz-erase-unzip-pkcrypt|zstd-unzip-pkcrypt|zstd-append-unzip-pkcrypt|zstd-erase-unzip-pkcrypt)"
+ )
+
+ # TODO: A bunch of tests end up looping and writing over each other's files
+ # It gets better with a patch applied (see https://github.com/zlib-ng/minizip-ng/issues/623#issuecomment-1264518994)
+ # but still hangs.
+ cmake_src_test -j1
+}
+
+multilib_src_install_all() {
+ if ! use compat && use test ; then
+ # Test binaries, bug #874591
+ rm "${ED}"/usr/bin/minigzip || die
+ rm "${ED}"/usr/bin/minizip-ng || die
+ fi
+}
+
+pkg_postinst() {
+ if use compat ; then
+ ewarn "minizip-ng is experimental and replacing the system zlib[minizip] is dangerous"
+ ewarn "Please be careful!"
+ fi
+}