summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.5.ebuild8
-rw-r--r--sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild8
3 files changed, 19 insertions, 6 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
index ff1e80b30fff..9a03b0678000 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
@@ -72,8 +72,13 @@ src_configure() {
local nolib_flags=( -nodefaultlibs -lc )
if use clang; then
- local -x CC=${CHOST}-clang
- local -x CXX=${CHOST}-clang++
+ # Only do this conditionally to allow overriding with
+ # e.g. CC=clang-13 in case of breakage
+ if ! tc-is-clang ; then
+ local -x CC=${CHOST}-clang
+ local -x CXX=${CHOST}-clang++
+ fi
+
strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.5.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.5.ebuild
index dcbada06ccf0..e5c0203110f9 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.5.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.5.ebuild
@@ -72,8 +72,12 @@ src_configure() {
local nolib_flags=( -nodefaultlibs -lc )
if use clang; then
- local -x CC=${CHOST}-clang
- local -x CXX=${CHOST}-clang++
+ # Only do this conditionally to allow overriding with
+ # e.g. CC=clang-13 in case of breakage
+ if ! tc-is-clang ; then
+ local -x CC=${CHOST}-clang
+ local -x CXX=${CHOST}-clang++
+ fi
strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
index 1a7cc5f2b724..c6913b149fa4 100644
--- a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
@@ -72,8 +72,12 @@ src_configure() {
local nolib_flags=( -nodefaultlibs -lc )
if use clang; then
- local -x CC=${CHOST}-clang
- local -x CXX=${CHOST}-clang++
+ # Only do this conditionally to allow overriding with
+ # e.g. CC=clang-13 in case of breakage
+ if ! tc-is-clang ; then
+ local -x CC=${CHOST}-clang
+ local -x CXX=${CHOST}-clang++
+ fi
strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"