summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/acpi_call/acpi_call-9999.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
index 8eddd39e1548..ba87b06a3dcf 100644
--- a/sys-power/acpi_call/acpi_call-9999.ebuild
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit linux-info linux-mod
@@ -11,7 +11,6 @@ if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
KEYWORDS=""
else
- inherit vcs-snapshot
SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -20,11 +19,10 @@ DESCRIPTION="A kernel module that enables you to call ACPI methods"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
MODULE_NAMES="acpi_call(misc:${S})"
-BUILD_TARGETS="default"
src_compile() {
BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"