summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/tuxedo-cc-wmi/Manifest1
-rw-r--r--sys-power/tuxedo-cc-wmi/metadata.xml9
-rw-r--r--sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4.ebuild23
3 files changed, 33 insertions, 0 deletions
diff --git a/sys-power/tuxedo-cc-wmi/Manifest b/sys-power/tuxedo-cc-wmi/Manifest
new file mode 100644
index 000000000000..1cbeb56e540a
--- /dev/null
+++ b/sys-power/tuxedo-cc-wmi/Manifest
@@ -0,0 +1 @@
+DIST tuxedo-cc-wmi-0.1.4.tar.gz 25089 BLAKE2B f71eedeb02a301caf27ef12326cc9c163631788c5b991e980e78b618ff767ab4c0f6a609ebffefb3afa830b781e6043bdb85b9e4659927838c280d0aaa3b300c SHA512 a41faa7290859410eb8446dd02ee2bdf87a3085882f3fc6b968701bb14bab87bd6bcd4bf9839111c62eab8a8751f8c2cf378aa7297879f7781f73998199e5f27
diff --git a/sys-power/tuxedo-cc-wmi/metadata.xml b/sys-power/tuxedo-cc-wmi/metadata.xml
new file mode 100644
index 000000000000..e42604230c16
--- /dev/null
+++ b/sys-power/tuxedo-cc-wmi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4.ebuild b/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4.ebuild
new file mode 100644
index 000000000000..990f9c91e1e5
--- /dev/null
+++ b/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo WMI"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-cc-wmi"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BUILD_TARGETS="all"
+MODULE_NAMES="tuxedo_cc_wmi(tuxedo:${S}:src)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}