summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/btop')
-rw-r--r--sys-process/btop/btop-1.2.7-r1.ebuild (renamed from sys-process/btop/btop-1.2.7.ebuild)12
1 files changed, 12 insertions, 0 deletions
diff --git a/sys-process/btop/btop-1.2.7.ebuild b/sys-process/btop/btop-1.2.7-r1.ebuild
index 44d1c8204f7d..59381b7f2690 100644
--- a/sys-process/btop/btop-1.2.7.ebuild
+++ b/sys-process/btop/btop-1.2.7-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit xdg-utils
+
DESCRIPTION="A monitor of resources"
HOMEPAGE="https://github.com/aristocratos/btop"
SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -30,3 +32,13 @@ src_install() {
dodoc README.md CHANGELOG.md
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}