summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/criu/files/2.3/criu-2.3-no-git.patch')
-rw-r--r--sys-process/criu/files/2.3/criu-2.3-no-git.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-process/criu/files/2.3/criu-2.3-no-git.patch b/sys-process/criu/files/2.3/criu-2.3-no-git.patch
new file mode 100644
index 000000000000..86360cdf1a55
--- /dev/null
+++ b/sys-process/criu/files/2.3/criu-2.3-no-git.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 97f63eb..0e2636b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -245,9 +245,9 @@ test: zdtm
+ # Generating tar requires tag matched CRIU_VERSION.
+ # If not found then simply use GIT's describe with
+ # "v" prefix stripped.
+-head-name := $(shell git tag -l v$(CRIU_VERSION))
++head-name := $(shell if [ -d ".git" ]; then git tag -l v$(CRIU_VERSION); fi)
+ ifeq ($(head-name),)
+- head-name := $(shell git describe 2>/dev/null)
++ head-name := $(shell if [ -d ".git" ]; then git describe 2>/dev/null; fi)
+ endif
+ # If no git tag could describe current commit,
+ # use pre-defined CRIU_VERSION with GITID (if any).