summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/ftop/ftop-1.0-r1.ebuild')
-rw-r--r--sys-process/ftop/ftop-1.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/ftop/ftop-1.0-r1.ebuild b/sys-process/ftop/ftop-1.0-r1.ebuild
new file mode 100644
index 000000000000..60b20fc17276
--- /dev/null
+++ b/sys-process/ftop/ftop-1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Monitor open files and filesystems"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-overflow.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}