summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/prll/prll-0.6.4.ebuild')
-rw-r--r--sys-process/prll/prll-0.6.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-process/prll/prll-0.6.4.ebuild b/sys-process/prll/prll-0.6.4.ebuild
new file mode 100644
index 000000000000..1d9cfb0e7449
--- /dev/null
+++ b/sys-process/prll/prll-0.6.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="A utility for parallelizing execution of shell functions"
+HOMEPAGE="https://github.com/exzombie/prll"
+SRC_URI="https://github.com/exzombie/prll/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+DOC_CONTENTS="
+You must source the prll.sh file located\nin /etc/profile.d to be able to use prll:\n
+ $ source /etc/profile.d/prll.sh
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/then sh/d' \
+ -e '/then zsh/d' \
+ -e '/then dash/d' \
+ -i tests/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+ readme.gentoo_create_doc
+ rm -rf "${D}/usr/share/doc/prll" || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}