summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/files/htop-3.0.0_beta5-gcc-10.patch52
-rw-r--r--sys-process/htop/htop-3.0.0_beta5.ebuild4
2 files changed, 54 insertions, 2 deletions
diff --git a/sys-process/htop/files/htop-3.0.0_beta5-gcc-10.patch b/sys-process/htop/files/htop-3.0.0_beta5-gcc-10.patch
new file mode 100644
index 000000000000..6a2004b3cf77
--- /dev/null
+++ b/sys-process/htop/files/htop-3.0.0_beta5-gcc-10.patch
@@ -0,0 +1,52 @@
+From ee711740d2809e7aa3ebd57d58bfc02b1e9b034b Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Thu, 23 Jan 2020 17:27:10 +0100
+Subject: [PATCH] Fix GCC 10 switch to `-fno-common` default
+
+---
+ CRT.h | 6 +++---
+ linux/LinuxProcess.h | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CRT.h b/CRT.h
+index 933fe068..65998ac6 100644
+--- a/CRT.h
++++ b/CRT.h
+@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
+
+ extern int CRT_delay;
+
+-int* CRT_colors;
++extern int* CRT_colors;
+
+ extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
+
+@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
+
+ extern int CRT_scrollWheelVAmount;
+
+-char* CRT_termType;
++extern char* CRT_termType;
+
+ // TODO move color scheme to Settings, perhaps?
+
+ extern int CRT_colorScheme;
+
+-void *backtraceArray[128];
++extern void *backtraceArray[128];
+
+ #if HAVE_SETUID_ENABLED
+
+diff --git a/linux/LinuxProcess.h b/linux/LinuxProcess.h
+index 6ce3037d..cbd77be9 100644
+--- a/linux/LinuxProcess.h
++++ b/linux/LinuxProcess.h
+@@ -144,7 +144,7 @@ typedef struct LinuxProcess_ {
+ #endif
+
+
+-long long btime; /* semi-global */
++extern long long btime; /* semi-global */
+
+ extern ProcessFieldData Process_fields[];
+
diff --git a/sys-process/htop/htop-3.0.0_beta5.ebuild b/sys-process/htop/htop-3.0.0_beta5.ebuild
index 9ee899432723..3351359ceb60 100644
--- a/sys-process/htop/htop-3.0.0_beta5.ebuild
+++ b/sys-process/htop/htop-3.0.0_beta5.ebuild
@@ -30,9 +30,9 @@ DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
PATCHES=(
-
# Fixes from upstream (can usually be removed with next version bump)
- "${FILESDIR}/${PN}-2.1.0-header_updates.patch"
+ "${FILESDIR}"/${PN}-2.1.0-header_updates.patch
+ "${FILESDIR}"/${PN}-3.0.0_beta5-gcc-10.patch
)
pkg_setup() {