summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/podofo-build/podofo-build-0.9.7-r1.ebuild')
-rw-r--r--virtual/podofo-build/podofo-build-0.9.7-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/podofo-build/podofo-build-0.9.7-r1.ebuild b/virtual/podofo-build/podofo-build-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..ef9f93e39312
--- /dev/null
+++ b/virtual/podofo-build/podofo-build-0.9.7-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Virtual package for building against PoDoFo"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+boost idn debug test +tools"
+RESTRICT="!test? ( test )"
+
+# Pull in boost for build-against header dependency (see bug #503802).
+RDEPEND="
+ app-text/podofo:0/${PV}[boost=,idn=,debug=,test=,tools=]
+ boost? ( dev-libs/boost )
+"