summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-greenlet/python-greenlet-1.0-r2.ebuild')
-rw-r--r--virtual/python-greenlet/python-greenlet-1.0-r2.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/virtual/python-greenlet/python-greenlet-1.0-r2.ebuild b/virtual/python-greenlet/python-greenlet-1.0-r2.ebuild
new file mode 100644
index 000000000000..988c8b2aaddf
--- /dev/null
+++ b/virtual/python-greenlet/python-greenlet-1.0-r2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python greenlet module"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~mips ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/greenlet[${PYTHON_USEDEP}]' 'python*')"