summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-typing/python-typing-0.ebuild')
-rw-r--r--virtual/python-typing/python-typing-0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-typing/python-typing-0.ebuild b/virtual/python-typing/python-typing-0.ebuild
new file mode 100644
index 000000000000..6249169a07c9
--- /dev/null
+++ b/virtual/python-typing/python-typing-0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python typing module"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' \
+ 'python2*' python3_4 'pypy*')"