summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/Manifest6
-rw-r--r--www-apps/dokuwiki/dokuwiki-20160626e.ebuild77
-rw-r--r--www-apps/dokuwiki/dokuwiki-20170219e.ebuild77
-rw-r--r--www-apps/dokuwiki/dokuwiki-20230404a-r1.ebuild (renamed from www-apps/dokuwiki/dokuwiki-20180422a.ebuild)25
-rw-r--r--www-apps/dokuwiki/dokuwiki-20240206a.ebuild (renamed from www-apps/dokuwiki/dokuwiki-20180422b.ebuild)26
-rw-r--r--www-apps/dokuwiki/metadata.xml10
6 files changed, 39 insertions, 182 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index 64daffe8e743..d8f9e704ea1a 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,4 +1,2 @@
-DIST dokuwiki-2016-06-26e.tgz 3464178 BLAKE2B cdeebee2f36cc899fcffe1d6df6f5beee8f7dd303db00a41fa4d187c27528971a8ea0fccffacb6331fe61f5854a9b2687ff55c2578d628164a39f817e4538a58 SHA512 b47c3a31b0bc731392703ed8d705717e7d1b75db0c44d822d8791c1e409d5285fe863a3dbd13bc60b73c01ca268f7a73a6a24c90edd211fd5c124d3a8be70039
-DIST dokuwiki-2017-02-19e.tgz 3505643 BLAKE2B 99fedb175fa8e1330a4ad14ed8d593edfc1edb9aeb7d8b9100e940fb4c5bfac9dada2fe395e030cff18b8c809e36211fc9d0bdc22d5be3fae7f243343704218a SHA512 6fadb64f9d8394731f346708849d8828b33f4f775e23bca97896b2e06bbfc3b70a6fc17d63dcef8199fdb0aaf0b8291eb0eebcdff7b81524b2d454229eb20be4
-DIST dokuwiki-2018-04-22a.tgz 3749191 BLAKE2B bb03b771e857a2db16ebd44d3f888af8e3c9dcd6fb5da2a549dc7c942ad87cb1e0aee6d3ed78edaa9df864804bf51cd18a17cf8a4123d12fac39405fe661bc04 SHA512 bf1dd7411abadedb395c9e12c7a9f5586fe078e59556b1ce66a5351c06f338406eca944d7589f40d8a9eb098da6ed0edc256f83ec8b19f6335415e2fe6c31284
-DIST dokuwiki-2018-04-22b.tgz 3745314 BLAKE2B 56c349c72038db83b5ae199ac1d6d00ef8566a00fdf2bc5a782e808e5205ae3ba5cfa47bdfc4f7fb0b2e493a22eed006517cfb46f7c0c57de748cfb800942f58 SHA512 6fc1fba8d93296d7cc795a4067e409339b3ce965ad38aefa42f1974d267ac05f199185e895a60d355ebe8371c68345fa51f2aea5871f955dbba1cdbdf8bedebf
+DIST dokuwiki-2023-04-04a.tgz 4043928 BLAKE2B a18372b04bd10760236ec4f976a87fed800601a541ebb6aaa07b302c8462286da3094aa102194a101c59ceacde99d0c865f938b8eb732cf09e8e7f0b5f40ea8e SHA512 748af27b2d226437f87461522254fca5e65c7572fdc20e75259944b388e3888a85f61120d1c22c671d3a302ac6791e463a0d3418f2fcf23bf046116107b11ab8
+DIST dokuwiki-2024-02-06a.tgz 4201385 BLAKE2B 3e4541f7e13e400e791af57a3caf7274b5ec7f4608396f7ff91c60f2991f7aea0db2b142a7425d1057a9fb2297200b8b85cbe55af592105927f333dfa228ba44 SHA512 280e450f47237f834256a3a6cd81efe74c82b24b06033d09485bba640d4fd5de72d4fa62129323a6a5f37796357cbe8d3dd1f31b658ca85819e4c9fc47665e2c
diff --git a/www-apps/dokuwiki/dokuwiki-20160626e.ebuild b/www-apps/dokuwiki/dokuwiki-20160626e.ebuild
deleted file mode 100644
index d6e837cfd1cc..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20160626e.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
-SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-5.3[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}
diff --git a/www-apps/dokuwiki/dokuwiki-20170219e.ebuild b/www-apps/dokuwiki/dokuwiki-20170219e.ebuild
deleted file mode 100644
index d6e837cfd1cc..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20170219e.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
-SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-5.3[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}
diff --git a/www-apps/dokuwiki/dokuwiki-20180422a.ebuild b/www-apps/dokuwiki/dokuwiki-20230404a-r1.ebuild
index 336c627e5ccd..9de0b60bb660 100644
--- a/www-apps/dokuwiki/dokuwiki-20180422a.ebuild
+++ b/www-apps/dokuwiki/dokuwiki-20230404a-r1.ebuild
@@ -1,25 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit webapp
# upstream uses dashes in the datestamp
MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+if [[ ${PV} == *rc* ]]; then
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ MY_P="${PN}-rc-${MY_BASE_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
+else
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
HOMEPAGE="https://wiki.dokuwiki.org"
-SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
IUSE="gd"
DEPEND=""
RDEPEND="
- >=dev-lang/php-5.3[xml]
+ >=dev-lang/php-8.0[xml]
virtual/httpd-php:*
gd? ( ||
(
@@ -31,8 +40,6 @@ RDEPEND="
need_httpd_cgi
-S="${WORKDIR}/${PN}-${MY_PV}"
-
src_prepare() {
# create initial changes file
touch data/changes.log
diff --git a/www-apps/dokuwiki/dokuwiki-20180422b.ebuild b/www-apps/dokuwiki/dokuwiki-20240206a.ebuild
index 1d99e100aff1..80ace2977efa 100644
--- a/www-apps/dokuwiki/dokuwiki-20180422b.ebuild
+++ b/www-apps/dokuwiki/dokuwiki-20240206a.ebuild
@@ -1,25 +1,33 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit webapp
# upstream uses dashes in the datestamp
MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+if [[ ${PV} == *rc* ]]; then
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ MY_P="${PN}-rc-${MY_BASE_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
+else
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
HOMEPAGE="https://wiki.dokuwiki.org"
-SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
IUSE="gd"
-DEPEND=""
RDEPEND="
- >=dev-lang/php-5.3[xml]
+ >=dev-lang/php-8.0[xml]
virtual/httpd-php:*
gd? ( ||
(
@@ -31,8 +39,6 @@ RDEPEND="
need_httpd_cgi
-S="${WORKDIR}/${PN}-${MY_PV}"
-
src_prepare() {
# create initial changes file
touch data/changes.log
diff --git a/www-apps/dokuwiki/metadata.xml b/www-apps/dokuwiki/metadata.xml
index 6cbe76a6b937..9e5234c9d3ab 100644
--- a/www-apps/dokuwiki/metadata.xml
+++ b/www-apps/dokuwiki/metadata.xml
@@ -1,14 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>jmbsvicetto@gentoo.org</email>
- <name>Jorge Manuel B. S. Vicetto</name>
- </maintainer>
<maintainer type="project">
<email>web-apps@gentoo.org</email>
<name>Gentoo Webapps</name>
</maintainer>
+ <stabilize-allarches/>
<longdescription lang="en">
DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at
creating documentation of any kind. It is targeted at developer teams,
@@ -17,4 +14,7 @@
eases the creation of structured texts. All data is stored in plain text
files - no database is required.
</longdescription>
+ <upstream>
+ <remote-id type="github">dokuwiki/dokuwiki</remote-id>
+ </upstream>
</pkgmetadata>