summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/drraw/drraw-2.1.3.ebuild')
-rw-r--r--www-apps/drraw/drraw-2.1.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-apps/drraw/drraw-2.1.3.ebuild b/www-apps/drraw/drraw-2.1.3.ebuild
new file mode 100644
index 000000000000..498ad54acc92
--- /dev/null
+++ b/www-apps/drraw/drraw-2.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp
+
+DESCRIPTION="drraw is a simple web based presentation front-end for RRDtool"
+HOMEPAGE="http://web.taranis.org/drraw"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/CGI
+ >=net-analyzer/rrdtool-1.2.1"
+
+need_httpd_cgi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s|/usr/local/bin/perl|/usr/bin/perl|" drraw.cgi
+ sed -i \
+ -e "s|/somewhere/drraw/saved|/tmp|" \
+ -e "s|/somewhere/drraw/tmp|/tmp|" \
+ drraw.conf
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGES INSTALL README.EVENTS WISHLIST
+ rm CHANGES INSTALL README.EVENTS WISHLIST
+
+ insinto "${MY_CGIBINDIR}"
+ doins drraw.conf
+
+ exeinto "${MY_CGIBINDIR}"
+ doexe drraw.cgi
+
+ insinto "${MY_ICONSDIR}"
+ doins icons/*.gif
+
+ webapp_configfile "${MY_CGIBINDIR}"/drraw.conf
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}