summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.1.0.ebuild')
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.1.0.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.1.0.ebuild
new file mode 100644
index 000000000000..82bd6e6ed2cd
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icinga Web 2 plugin for Graphite"
+HOMEPAGE="https://www.icinga.com/docs/graphite/latest/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="amd64 x86"
+ SRC_URI="https://github.com/Icinga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.0
+ >=www-apps/icingaweb2-2.5.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/graphite/"
+ doins -r "${S}"/*
+}