summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/nanoc-checking/nanoc-checking-1.0.1.ebuild')
-rw-r--r--www-apps/nanoc-checking/nanoc-checking-1.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-apps/nanoc-checking/nanoc-checking-1.0.1.ebuild b/www-apps/nanoc-checking/nanoc-checking-1.0.1.ebuild
new file mode 100644
index 000000000000..63b0d6c7e17d
--- /dev/null
+++ b/www-apps/nanoc-checking/nanoc-checking-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby26 ruby27"
+
+# Upstream has specs but they are not available in the gem and the
+# repository upstream is not tagged for this.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides checking functionality for Nanoc"
+HOMEPAGE="https://nanoc.ws/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "
+ >=www-apps/nanoc-cli-4.11.15:0
+ >=www-apps/nanoc-core-4.11.15:0
+"