summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/nanoc-deploying/nanoc-deploying-1.0.2-r1.ebuild')
-rw-r--r--www-apps/nanoc-deploying/nanoc-deploying-1.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/nanoc-deploying/nanoc-deploying-1.0.2-r1.ebuild b/www-apps/nanoc-deploying/nanoc-deploying-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..581d016f0e25
--- /dev/null
+++ b/www-apps/nanoc-deploying/nanoc-deploying-1.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+# Upstream has specs but they are not available in the gem and the
+# repository upstream is not tagged for this.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides deploying functionality for Nanoc"
+HOMEPAGE="https://nanoc.app/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "
+ www-apps/nanoc-checking:1
+ >=www-apps/nanoc-cli-4.11.15:0
+ >=www-apps/nanoc-core-4.11.15:0
+"