summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/Manifest4
-rw-r--r--www-apps/roundup/metadata.xml6
-rw-r--r--www-apps/roundup/roundup-1.5.1.ebuild39
-rw-r--r--www-apps/roundup/roundup-1.6.1-r1.ebuild41
-rw-r--r--www-apps/roundup/roundup-2.2.0.ebuild55
-rw-r--r--www-apps/roundup/roundup-2.3.0.ebuild78
6 files changed, 140 insertions, 83 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
index b97d22ec5105..8163a9198eaa 100644
--- a/www-apps/roundup/Manifest
+++ b/www-apps/roundup/Manifest
@@ -1,2 +1,2 @@
-DIST roundup-1.5.1.tar.gz 2618886 BLAKE2B 5ccca10ce7f30b35b0875340c4cae87aa19e5384e6e5973576ea8e2de79eb83d32447580944f472d73e7cdb5f43a4ed7f805d51242e22cc2f756b3deae4004b2 SHA512 d7cdeaafb682ce7f202cacddeb1a42312f22778a2c83b52b4e838c27b1e7141a94b2ac2b670b0edee0efcfe27d74e31e6f267ae1380e90359def27385ca68d58
-DIST roundup-1.6.1.tar.gz 3128618 BLAKE2B 7fa87006582feac74f0fc455bc201f2485326b8f6ed616164f667992da114d45e8d8cef370a825450b5a4cb757ba0453d5fe3ace47164bd83e78a8c6f28b9d05 SHA512 b7666c5515c76baa4fa3ac3d0efea82feace6270af55bbc70e603b2ce0c617b4a303a15133310c1e00d3b6442baa58060d5387f568014652b1b781d9248f0052
+DIST roundup-2.2.0.tar.gz 3722236 BLAKE2B f9f36ff2a49c769dcce38dd59fd88825cb3a6560fbfc2a7bbf6d2abf1388bb328da5aa7de2934ae2469163bb4f125b4438b07f1eff9082458768012b4eda7687 SHA512 dbaf7c4a5e7fb75f0e401f39962c8f5a3b088036a0f2c9efb2910f3941df35df6c345c2051c37cbdcc9a2049d82d09bcb4e15b368f8c4c77fa4b4bf80c6dc844
+DIST roundup-2.3.0.tar.gz 3880745 BLAKE2B a6ed278352a91893cd5706b8e5c9fcbed76fc35364cb3709371187ba27b459efa4676ed8a342c937fcd2b637f21714379acdec21631e6c9012ab6a8bf3cebfcd SHA512 83c659ce8d268f4f7f16f10731371ed6320564635e2620e2502e600c4ddbcae92f5c46722a33c66aceef5a8af99f5c556bce5512f03b97ff0cfb88e8bafe7cb6
diff --git a/www-apps/roundup/metadata.xml b/www-apps/roundup/metadata.xml
index 499f901ab9c1..c4d4ede43783 100644
--- a/www-apps/roundup/metadata.xml
+++ b/www-apps/roundup/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>web-apps@gentoo.org</email>
@@ -9,6 +9,7 @@
<email>cedk@gentoo.org</email>
<name>Cédric Krier</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">roundup</remote-id>
<remote-id type="sourceforge">roundup</remote-id>
@@ -17,5 +18,8 @@
<flag name="tz">Enable full support of timezone</flag>
<flag name="xapian">Enable Xapian full-text indexer</flag>
<flag name="whoosh">Enable Whoosh full-text indexer</flag>
+ <flag name="jinja">Enable Jinja2 support</flag>
+ <flag name="pyjwt">Enable jwt tokens for login</flag>
+ <flag name="markdown">Enable markdown rendering</flag>
</use>
</pkgmetadata>
diff --git a/www-apps/roundup/roundup-1.5.1.ebuild b/www-apps/roundup/roundup-1.5.1.ebuild
deleted file mode 100644
index 7a2714a3718d..000000000000
--- a/www-apps/roundup/roundup-1.5.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
-HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT ZPL"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-DOCS="CHANGES.txt doc/*.txt"
-
-python_install_all() {
- distutils-r1_python_install_all
- rm -r "${ED}"/usr/share/doc/${PN} || die
- dohtml -r doc/*
-}
-
-pkg_postinst() {
- ewarn "As a non privileged user! (not root)"
- ewarn "Run 'roundup-admin install' to set up a roundup instance"
- ewarn "Then edit your config.ini file in the tracker home you setup"
- ewarn "Run 'roundup-admin initialise' to setup the admin pass"
- ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
- ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
- ewarn "log is in [tracker home]/roundup.log"
- ewarn "pid file is in [tracker home]/roundup.pid"
- ewarn
- ewarn "See upgrading.txt for upgrading instructions."
-}
diff --git a/www-apps/roundup/roundup-1.6.1-r1.ebuild b/www-apps/roundup/roundup-1.6.1-r1.ebuild
deleted file mode 100644
index 7d88bde098f4..000000000000
--- a/www-apps/roundup/roundup-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
-HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT ZPL"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="+tz sqlite mysql postgres xapian whoosh ssl"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- tz? ( dev-python/pytz[$PYTHON_USEDEP] )
- sqlite? ( dev-lang/python:*[sqlite] )
- mysql? ( dev-python/mysql-python[$PYTHON_USEDEP] )
- postgres? (
- >=dev-python/psycopg-1.1.21[$PYTHON_USEDEP]
- <dev-python/psycopg-2.8[$PYTHON_USEDEP]
- )
- xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
- whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
- ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )"
-
-DOCS="CHANGES.txt doc/*.txt"
-
-python_install_all() {
- distutils-r1_python_install_all
- rm -r "${ED}"/usr/share/doc/${PN} || die
-}
-
-pkg_postinst() {
- ewarn "See installation.txt for initialisation instructions."
- ewarn "See upgrading.txt for upgrading instructions."
-}
diff --git a/www-apps/roundup/roundup-2.2.0.ebuild b/www-apps/roundup/roundup-2.2.0.ebuild
new file mode 100644
index 000000000000..d82993a48cd1
--- /dev/null
+++ b/www-apps/roundup/roundup-2.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="https://roundup.sourceforge.io https://pypi.org/project/roundup/"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
+
+RDEPEND="
+ jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ markdown? (
+ || (
+ dev-python/markdown[$PYTHON_USEDEP]
+ dev-python/markdown2[$PYTHON_USEDEP]
+ dev-python/mistune[$PYTHON_USEDEP]
+ )
+ )
+ mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
+ pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
+ tz? ( dev-python/pytz[$PYTHON_USEDEP] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
+"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this test fails (for both py3.10 and py3.11, and it also fails in 2.1.0)
+ # upstream report https://issues.roundup-tracker.org/issue2551272
+ test/test_templating.py::Markdown2TestCase::test_string_markdown_code_block_attribute
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}"/usr/share/doc/${PN}/html "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}
diff --git a/www-apps/roundup/roundup-2.3.0.ebuild b/www-apps/roundup/roundup-2.3.0.ebuild
new file mode 100644
index 000000000000..e8fc8857ed1f
--- /dev/null
+++ b/www-apps/roundup/roundup-2.3.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="https://roundup.sourceforge.io https://pypi.org/project/roundup/"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown test"
+
+RDEPEND="
+ jinja? ( dev-python/jinja[${PYTHON_USEDEP}] )
+ markdown? (
+ || (
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/mistune[${PYTHON_USEDEP}]
+ )
+ )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg:0[${PYTHON_USEDEP}] )
+ pyjwt? ( dev-python/pyjwt[${PYTHON_USEDEP}] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ tz? ( dev-python/pytz[${PYTHON_USEDEP}] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[${PYTHON_USEDEP}] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,${PYTHON_USEDEP}] )
+"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tries to connect to non-running server
+ test/test_liveserver.py::TestPostgresWsgiServer
+ test/test_sqlite.py::sqliteSessionTest
+ test/test_sqlite.py::sqliteSpecialActionTestCase::testInnerMain
+ # automagic, assumes a postgresql server is available
+ test/test_config.py::TrackerConfig::testLoadSessionDbRedis
+
+ # upstream issue: https://issues.roundup-tracker.org/issue2551335
+ test/test_templating.py::Markdown2TestCase::test_markdown_hyperlinked_url
+ # upstream issue: https://issues.roundup-tracker.org/issue2551336
+ test/test_templating.py::Markdown2TestCase::test_string_markdown_link_item
+)
+
+python_install() {
+ distutils-r1_python_install
+ if [[ -d "${ED}"/usr/share ]]; then
+ rm -r "${D}$(python_get_sitedir)"/usr
+ else
+ mv "${D}$(python_get_sitedir)"/usr/share "${ED}"/usr/ || die
+ dodir /usr/share/doc/${PF}
+ mv "${ED}"/usr/share/doc/${PN}/html "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${PN} || die
+ rmdir "${D}$(python_get_sitedir)"/usr || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}"/usr/share/roundup -name __pycache__ -type d -exec rm -r {} +
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}