summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/rutorrent/rutorrent-9999.ebuild')
-rw-r--r--www-apps/rutorrent/rutorrent-9999.ebuild54
1 files changed, 33 insertions, 21 deletions
diff --git a/www-apps/rutorrent/rutorrent-9999.ebuild b/www-apps/rutorrent/rutorrent-9999.ebuild
index ad651140c198..f7dbb6ae40d3 100644
--- a/www-apps/rutorrent/rutorrent-9999.ebuild
+++ b/www-apps/rutorrent/rutorrent-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit webapp
+inherit webapp optfeature
DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
HOMEPAGE="https://github.com/Novik/ruTorrent"
@@ -13,41 +13,45 @@ if [[ ${PV} == 9999 ]]; then
else
SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
fi
-LICENSE="GPL-2"
-IUSE=""
+LICENSE="GPL-2+ MIT"
-need_httpd_cgi
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
-DEPEND="dev-lang/php[xml,gd]"
-RDEPEND="virtual/httpd-php"
+need_httpd_cgi
pkg_setup() {
webapp_pkg_setup
}
-src_prepare() {
- default
- find -name '\.gitignore' -type f -exec rm -rf {} \;
- if [[ ${PV} == 9999 ]]; then
- rm -rf .git
- fi
-}
-
src_install() {
webapp_src_preinst
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
insinto "${MY_HTDOCSDIR}"
doins -r .
+ # can not use fperms beacuse of globbing
chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
- "$ED${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
- webapp_serverowned "${MY_HTDOCSDIR}"/share
- webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
- webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
- webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
@@ -57,3 +61,11 @@ src_install() {
webapp_src_install
}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}