summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/ttyd/ttyd-9999.ebuild')
-rw-r--r--www-apps/ttyd/ttyd-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/www-apps/ttyd/ttyd-9999.ebuild b/www-apps/ttyd/ttyd-9999.ebuild
index adbcac55b7f7..3fdbd114e567 100644
--- a/www-apps/ttyd/ttyd-9999.ebuild
+++ b/www-apps/ttyd/ttyd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,20 +20,22 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="mbedtls"
DEPEND="
dev-libs/json-c:=
dev-libs/libuv:=
- net-libs/libwebsockets:=[libuv,ssl]
+ net-libs/libwebsockets:=[libuv,mbedtls=,ssl]
sys-libs/zlib:=
+ !mbedtls? ( dev-libs/openssl:= )
"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
src_install() {
- dobin ../${P}_build/${PN}
- doman man/*.1
+ cmake_src_install
+
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
newconfd "${FILESDIR}/${PN}.confd" "${PN}"
systemd_dounit "${FILESDIR}"/${PN}.service