summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/webmcp/files')
-rw-r--r--www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch42
1 files changed, 21 insertions, 21 deletions
diff --git a/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch b/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch
index 2fa1eb4aff53..3b399fe96ad9 100644
--- a/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch
+++ b/www-apps/webmcp/files/webmcp-1.2.6-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2013-03-12 21:49:03.976676966 +0100
-+++ Makefile 2013-03-12 21:50:02.888103540 +0100
+--- a/Makefile 2013-03-12 21:49:03.976676966 +0100
++++ b/Makefile 2013-03-12 21:50:02.888103540 +0100
@@ -1,11 +1,11 @@
include Makefile.options
@@ -34,8 +34,8 @@
symlinks::
ln -s -f ../../libraries/atom/atom.lua framework/lib/
---- Makefile.options.old 2015-05-26 21:43:41.354197822 +0200
-+++ Makefile.options 2015-05-26 22:01:34.594735786 +0200
+--- a/Makefile.options 2015-05-26 21:43:41.354197822 +0200
++++ b/Makefile.options 2015-05-26 22:01:34.594735786 +0200
@@ -14,13 +14,13 @@
# C compiler flags
# TODO: check alternatives to -D_GNU_SOURCE -fPIC
@@ -49,13 +49,13 @@
# linker flags
-LDFLAGS = -shared -L /usr/lib -L /usr/local/lib
-+LDFLAGS = -shared
++LDFLAGS = -shared $(MYLDFLAGS)
# additional linker flags for parts which depend on PostgreSQL
-LDFLAGS_PGSQL = -L /usr/local/lib/postgresql -rpath /usr/local/lib/postgresql
+LDFLAGS_PGSQL =
---- libraries/extos/Makefile.old 2013-03-13 21:49:19.710360750 +0100
-+++ libraries/extos/Makefile 2013-03-13 21:49:47.778096460 +0100
+--- a/libraries/extos/Makefile 2013-03-13 21:49:19.710360750 +0100
++++ b/libraries/extos/Makefile 2013-03-13 21:49:47.778096460 +0100
@@ -1,7 +1,7 @@
include ../../Makefile.options
@@ -65,8 +65,8 @@
extos.o: extos.c
$(CC) -c $(CFLAGS) -o extos.o extos.c
---- libraries/mondelefant/Makefile.old 2013-03-13 21:52:54.884250479 +0100
-+++ libraries/mondelefant/Makefile 2013-03-13 21:53:27.511932686 +0100
+--- a/libraries/mondelefant/Makefile 2013-03-13 21:52:54.884250479 +0100
++++ b/libraries/mondelefant/Makefile 2013-03-13 21:53:27.511932686 +0100
@@ -1,7 +1,7 @@
include ../../Makefile.options
@@ -76,8 +76,8 @@
mondelefant_native.o: mondelefant_native.c
$(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
---- libraries/multirand/Makefile.old 2013-03-13 21:54:29.399328173 +0100
-+++ libraries/multirand/Makefile 2013-03-13 21:54:58.019048434 +0100
+--- a/libraries/multirand/Makefile 2013-03-13 21:54:29.399328173 +0100
++++ b/libraries/multirand/Makefile 2013-03-13 21:54:58.019048434 +0100
@@ -1,7 +1,7 @@
include ../../Makefile.options
@@ -87,8 +87,8 @@
multirand.o: multirand.c
$(CC) -c $(CFLAGS) -o multirand.o multirand.c
---- libraries/extos/extos.c.old 2013-04-05 23:19:52.028115226 +0200
-+++ libraries/extos/extos.c 2013-04-05 23:20:14.819896253 +0200
+--- a/libraries/extos/extos.c 2013-04-05 23:19:52.028115226 +0200
++++ b/libraries/extos/extos.c 2013-04-05 23:20:14.819896253 +0200
@@ -12,6 +12,7 @@
#include <fcntl.h>
#include <poll.h>
@@ -97,8 +97,8 @@
#define EXTOS_MAX_ERRLEN 80
#define EXTOS_EXEC_MAX_ARGS 64
---- framework/accelerator/Makefile.old 2014-06-21 20:15:21.019918183 +0200
-+++ framework/accelerator/Makefile 2014-06-21 20:15:44.700471794 +0200
+--- a/framework/accelerator/Makefile 2014-06-21 20:15:21.019918183 +0200
++++ b/framework/accelerator/Makefile 2014-06-21 20:15:44.700471794 +0200
@@ -4,7 +4,7 @@
$(LD) $(LDFLAGS) -o webmcp_accelerator.$(SLIB_EXT) webmcp_accelerator.o
@@ -108,8 +108,8 @@
clean::
rm -f webmcp_accelerator.so webmcp_accelerator.o
---- libraries/extos/Makefile.old 2014-06-21 20:18:25.594611956 +0200
-+++ libraries/extos/Makefile 2014-06-21 20:18:50.457183029 +0200
+--- a/libraries/extos/Makefile 2014-06-21 20:18:25.594611956 +0200
++++ b/libraries/extos/Makefile 2014-06-21 20:18:50.457183029 +0200
@@ -4,7 +4,7 @@
$(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
@@ -119,8 +119,8 @@
clean::
rm -f extos.so extos.o
---- libraries/mondelefant/Makefile.old 2014-06-21 20:19:58.218962359 +0200
-+++ libraries/mondelefant/Makefile 2014-06-21 20:20:24.527476578 +0200
+--- a/libraries/mondelefant/Makefile 2014-06-21 20:19:58.218962359 +0200
++++ b/libraries/mondelefant/Makefile 2014-06-21 20:20:24.527476578 +0200
@@ -4,7 +4,7 @@
$(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
@@ -130,8 +130,8 @@
test:: mondelefant_native.so mondelefant.lua
lua -l mondelefant
---- libraries/multirand/Makefile.old 2014-06-21 20:21:36.950197127 +0200
-+++ libraries/multirand/Makefile 2014-06-21 20:22:04.967703944 +0200
+--- a/libraries/multirand/Makefile 2014-06-21 20:21:36.950197127 +0200
++++ b/libraries/multirand/Makefile 2014-06-21 20:22:04.967703944 +0200
@@ -4,7 +4,7 @@
$(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua