summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/radarr-bin/Manifest (renamed from www-apps/radarr/Manifest)0
-rw-r--r--www-apps/radarr-bin/files/radarr.init (renamed from www-apps/radarr/files/radarr.init)0
-rw-r--r--www-apps/radarr-bin/files/radarr.logrotate (renamed from www-apps/radarr/files/radarr.logrotate)0
-rw-r--r--www-apps/radarr-bin/files/radarr.service (renamed from www-apps/radarr/files/radarr.service)0
-rw-r--r--www-apps/radarr-bin/metadata.xml (renamed from www-apps/radarr/metadata.xml)0
-rw-r--r--www-apps/radarr-bin/radarr-bin-5.4.3.8677.ebuild78
-rw-r--r--www-apps/radarr/radarr-5.4.3.8677.ebuild67
7 files changed, 78 insertions, 67 deletions
diff --git a/www-apps/radarr/Manifest b/www-apps/radarr-bin/Manifest
index 7ecbdf0d856d..7ecbdf0d856d 100644
--- a/www-apps/radarr/Manifest
+++ b/www-apps/radarr-bin/Manifest
diff --git a/www-apps/radarr/files/radarr.init b/www-apps/radarr-bin/files/radarr.init
index 8abff709a970..8abff709a970 100644
--- a/www-apps/radarr/files/radarr.init
+++ b/www-apps/radarr-bin/files/radarr.init
diff --git a/www-apps/radarr/files/radarr.logrotate b/www-apps/radarr-bin/files/radarr.logrotate
index 166b80807334..166b80807334 100644
--- a/www-apps/radarr/files/radarr.logrotate
+++ b/www-apps/radarr-bin/files/radarr.logrotate
diff --git a/www-apps/radarr/files/radarr.service b/www-apps/radarr-bin/files/radarr.service
index daff14f543b1..daff14f543b1 100644
--- a/www-apps/radarr/files/radarr.service
+++ b/www-apps/radarr-bin/files/radarr.service
diff --git a/www-apps/radarr/metadata.xml b/www-apps/radarr-bin/metadata.xml
index 49ea8bc60df5..49ea8bc60df5 100644
--- a/www-apps/radarr/metadata.xml
+++ b/www-apps/radarr-bin/metadata.xml
diff --git a/www-apps/radarr-bin/radarr-bin-5.4.3.8677.ebuild b/www-apps/radarr-bin/radarr-bin-5.4.3.8677.ebuild
new file mode 100644
index 000000000000..c3c1e324bf75
--- /dev/null
+++ b/www-apps/radarr-bin/radarr-bin-5.4.3.8677.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="A fork of Sonarr to work with movies a la Couchpotato"
+HOMEPAGE="https://www.radarr.video/
+ https://github.com/Radarr/Radarr/"
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-x64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-x64.tar.gz
+ )
+ )
+ arm? (
+ elibc_glibc? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-arm.tar.gz
+ )
+ )
+ arm64? (
+ elibc_glibc? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-arm64.tar.gz
+ )
+ )
+"
+S="${WORKDIR}/Radarr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/radarr
+ acct-user/radarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Radarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/jellyfin.init" jellyfin
+
+ keepdir /var/lib/jellyfin
+ fowners -R jellyfin:jellyfin /var/lib/jellyfin
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/jellyfin.logrotate" jellyfin
+
+ dodir "/opt/jellyfin"
+ cp -R "${S}/." "${D}/opt/radarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/radarr.service"
+ systemd_newunit "${FILESDIR}/radarr.service" "jellyfin@.service"
+}
diff --git a/www-apps/radarr/radarr-5.4.3.8677.ebuild b/www-apps/radarr/radarr-5.4.3.8677.ebuild
deleted file mode 100644
index 8443b34a8a18..000000000000
--- a/www-apps/radarr/radarr-5.4.3.8677.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-SRC_URI="
- amd64? (
- elibc_glibc? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-x64.tar.gz )
- elibc_musl? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-x64.tar.gz )
- )
- arm? (
- elibc_glibc? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm.tar.gz )
- elibc_musl? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-arm.tar.gz )
- )
- arm64? (
- elibc_glibc? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-core-arm64.tar.gz )
- elibc_musl? ( https://github.com/Radarr/Radarr/releases/download/v${PV}/Radarr.develop.${PV}.linux-musl-core-arm64.tar.gz )
- )
-"
-
-DESCRIPTION="A fork of Sonarr to work with movies a la Couchpotato"
-HOMEPAGE="https://www.radarr.video"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="bindist strip test"
-
-RDEPEND="
- acct-group/radarr
- acct-user/radarr
- media-video/mediainfo
- dev-libs/icu
- dev-util/lttng-ust:0
- dev-db/sqlite
- sys-libs/glibc
-"
-
-QA_PREBUILT="*"
-
-S="${WORKDIR}/Radarr"
-
-src_prepare() {
- default
-
- # https://github.com/dotnet/runtime/issues/57784
- rm libcoreclrtraceptprovider.so Radarr.Update/libcoreclrtraceptprovider.so || die
-}
-
-src_install() {
- newinitd "${FILESDIR}/${PN}.init" ${PN}
-
- keepdir /var/lib/${PN}
- fowners -R ${PN}:${PN} /var/lib/${PN}
-
- insinto /etc/logrotate.d
- insopts -m0644 -o root -g root
- newins "${FILESDIR}/${PN}.logrotate" ${PN}
-
- dodir "/opt/${PN}"
- cp -R "${S}/." "${D}/opt/radarr" || die "Install failed!"
-
- systemd_dounit "${FILESDIR}/radarr.service"
- systemd_newunit "${FILESDIR}/radarr.service" "${PN}@.service"
-}