summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/bugzilla/bugzilla-4.4.12-r2.ebuild11
-rw-r--r--www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild11
-rw-r--r--www-apps/bugzilla/files/bugzilla-5.0.3-leftbrace.patch26
3 files changed, 42 insertions, 6 deletions
diff --git a/www-apps/bugzilla/bugzilla-4.4.12-r2.ebuild b/www-apps/bugzilla/bugzilla-4.4.12-r2.ebuild
index 2d6b66fd871d..9668d236f5d0 100644
--- a/www-apps/bugzilla/bugzilla-4.4.12-r2.ebuild
+++ b/www-apps/bugzilla/bugzilla-4.4.12-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -75,6 +75,10 @@ RDEPEND="
want_apache modperl
need_httpd_cgi
+PATCHES=(
+ "${FILESDIR}/${PN}"-5.0.3-leftbrace.patch
+)
+
pkg_setup() {
depend.apache_pkg_setup modperl
webapp_pkg_setup
@@ -86,11 +90,12 @@ src_prepare() {
# Remove bundled perl modules
rm -r lib/ || die
- eapply_user
+
+ default
}
src_test() {
- perl runtests.pl || die
+ perl -I. runtests.pl || die
}
src_install () {
diff --git a/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild b/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
index 0675641f3211..feb026881ffe 100644
--- a/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
+++ b/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -79,6 +79,10 @@ RDEPEND="
want_apache modperl
need_httpd_cgi
+PATCHES=(
+ "${FILESDIR}/${PN}"-5.0.3-leftbrace.patch
+)
+
pkg_setup() {
depend.apache_pkg_setup modperl
webapp_pkg_setup
@@ -90,11 +94,12 @@ src_prepare() {
# Remove bundled perl modules
rm -r lib/ || die
- eapply_user
+
+ default
}
src_test() {
- perl runtests.pl || die
+ perl -I. runtests.pl || die
}
src_install () {
diff --git a/www-apps/bugzilla/files/bugzilla-5.0.3-leftbrace.patch b/www-apps/bugzilla/files/bugzilla-5.0.3-leftbrace.patch
new file mode 100644
index 000000000000..f5704406d875
--- /dev/null
+++ b/www-apps/bugzilla/files/bugzilla-5.0.3-leftbrace.patch
@@ -0,0 +1,26 @@
+From 3c60fba26b1fa51ec302d05dc6e76236d2f54ba4 Mon Sep 17 00:00:00 2001
+From: Simon Green <mail@simon.green>
+Date: Sun, 30 Oct 2016 14:55:23 +1000
+Subject: [PATCH] Bug 228444 - Checking for unquoted non regex variable
+ interpolated into regex
+
+---
+ t/010dependencies.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/010dependencies.t b/t/010dependencies.t
+index 4b7ca223d..1b6c270a8 100644
+--- a/t/010dependencies.t
++++ b/t/010dependencies.t
+@@ -69,7 +69,7 @@ foreach my $module (keys %mods) {
+ $used =~ s#/#::#g;
+ $used =~ s#\.pm$##;
+ $used =~ s#\$module#[^:]+#;
+- $used =~ s#\${[^}]+}#[^:]+#;
++ $used =~ s#\$\{[^}]+}#[^:]+#;
+ $used =~ s#[" ]##g;
+ push(@use, grep(/^\Q$used\E$/, keys %mods));
+ }
+--
+2.20.1
+